I can connect the phone to Wi-FI manually, but after several minutes, it loses the connection, and I have to restore it manually. This did not happen before I installed iOS 12.


Before doing anything, have you erased network settings and verified WiFi is stable?

Next, erase all content and settings and retest on a new network.

Apple typically stops signing the previous release within a week of a new iOS, so you could try restoring back to iOS 11 to rule out a hardware failure that was a coincidence. At that point you can decide to see Apple service before upgrading to understand if you have any recourse from them in case a second upgrade also fails.

Many many iPhone 7 era devices work fine, so it’s almost certainly not a widespread bug. If you’re sure you want iOS 12 I would erase and restore the device and then connect to a Mac to look over the system logs if the failure continues.


Thanks, the reset of network settings did it. I'm annoyed at myself because I was so sure it was duet iOS12 that I didn't do theobvious.

  • Bob - thanks for confirming. If you use the "contact us" link - you can merge your two accounts and then tick the "solved" check mark so others know it worked. I'm super glad it was not anything hard like a failure / repair. It's natural to try and think what changed last when things break. – bmike Sep 22 '18 at 20:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .