I've reinstalled my dad's MacBook Air and now, for some reason, we can see the postal address next to name and surname in Mail. I've attached a photo.

As you can see, the photo shows a random email sent to us displaying name and surname like it should, but also the postal address. How can I disable it so the postal address is not shown?

enter image description here


1 Answer 1


That is a Junk mail.

What they put in the TO field you can not change.

Somehow they have your Dads address in they records and put it in the TO field for some obscure reason.

However if you wish not to see emails like that then

Select that email

Click on Mail (top left)

then Preferences

and select rules

Now set it up as shown, and emails from CheapOAir will be Automatically deleted. You can undo this if you want to see them again.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .