1

My macbook 13inch late 2013 on highsierra gives me the blackscreen+cursor after I login. After I googled it, I found a fix involving the single user mode, but when I do press command+S it shows the lines for a fraction of a second and then automatically it goes to the login screen. I recorded a video of this and took a screenshot (see bellow) Single User Mode

Then, I tried command+R > Recovery Mode > Disc Utility > First Aid, it said it's all cool but nothing changed. Black Screen + cursor yet again.

Then, I tried the Shift Key in order to go to Safe Mode, doesnt work, I tried it multiple times, powerup while pressing it until I see the login screen but it loads the regular one.

Lastly, i tried to reset the NVRAM with opt + comm + P + R three times and then go to single user mode. In the first many times I got nothing, in n-th time it somehow worked, I did input the five commands many people online suggest (/sbin/fsck -fy /sbin/mount -uw / rm -f /Library/Preferences/com.apple.loginwindow.plist rm -f /var/db/.AppleUpgrade reboot) but now when I input the password and try to login it stays at 90% of the loading bar for a long time. I'ts currently there as I type.

Don't know if it's relevant but I only have the admin user, no guests, never had a similar problem and my last time machine backup is from 10-15 days ago. I could go back but i'd strongly prefer not to lose the files added in these days.

Any help would be super appreciated guys, thanks.

  • it looks like you have disk problems. Do you have USB boot disk ? – Ruskes Sep 21 '18 at 3:30
  • 1
    No, actually i don't even know what this is (i will google it and find out). Btw i went to recovery mode, restored from time machine backup and now it works. Lost some work i had done but whatever, now i'm typing at this laptop. If it was a disk problem could this still happen? I'm afraid that it will happen again. – ineedhelplol Sep 21 '18 at 7:42

You must log in to answer this question.

Browse other questions tagged .