3

I am using iTerm2 under High Sierra 10.13.6. iTerm2 lets me assign Control-Command key combos to particular actions. This mostly works fine, but at least two of these do nothing: Control-Command-B and Control-Command-D. I suspect they are being grabbed by something at the system level. However, manually walking through all of System Preferences -> Keyboard -> Shortcuts didn't show anything for these two.

Is there a way to get a list of all key combinations and map them to what they are (or are not) assigned to?

3
+25

There are a few apps out there which are meant to help show the available keyboard commands. The only ones I can remember right now are:

  1. KeyCue which is €19.99 but does have a trial. I suspect this is probably the best of the bunch, although it’s the most expensive.

  2. CheatSheet is another one, which is free, although it doesn't show nearly as many shortcuts as KeyCue does.

(If I can remember others I will edit this to add them)

Unfortunately, when I tried KeyCue and CheatSheet, neither of them showed anything for ⌃⌘D or ⌃⌘B.

I know that ⌃⌘Dis used for the system dictionary (highlight a word, press ⌃⌘D and you’ll get a dictionary lookup for it). But I don’t see a preference for it in System Preferences to allow you to disable it or re-assign it.

Also ⌃⌘B doesn’t seem to do anything on my Mac, so that may be specific to some app that you have installed.

Be sure to check the ”Services” area of Keyboard preferences:

enter image description here

That’s where I usually find the culprit when something has stolen a keyboard shortcut that I want to use.

  • If neither of them even found ⌃⌘D, that's not helpful. And I did look through Services, and have nothing selected at all. – Paul Hoffman Sep 24 '18 at 23:13
  • It's possible that the program that is taking/'hijacking' the shortcuts is put together poorly and isn't doing them in a way that Apple/these programs can recognize. Have you tried to maybe create a shortcut using the same combination and in keyboard shortcuts and seeing if anything pops up telling you you have a conflict? Also, try to close down all your startup programs and check activity monitor to see if you have apps that you don't recognize/might be using them – Talos Potential Sep 24 '18 at 23:26
0

Unfortunately Matt Sephton's correct answer is hidden as "comment" under your basic Question:

You're correct that those two shortcuts are system editing. You can disable the Cmd+Ctrl+D combo using apple.stackexchange.com/questions/22785/…Matt Sephton Sep 25 at 12:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.