I've set up my own domain (say owndomain.com) to forward all his e-mail to my personal Gmail account. It works great and once setup, I can send e-mails from the iPhone using that account with the coma trick, but it will also show "via gmail" after the address.

Any idea on how to avoid that?


2 Answers 2


Assume your email address is "[email protected]" and your other email address is "[email protected]."

When you setup an email account on your iPhone, you tell it which account you want to to use to log in and send/receive email.

You can change the "From:" line to be anything you want (using the "comma trick" on iOS or other settings in other mail clients), but Google does not want you to be able to "spoof" your email address without making it clear which account it came from. The reasons for this should be obvious.

When you send email, you connect to a SMTP server and give your username and password. if that username is "[email protected]" and the "From:" line is "[email protected]" then Gmail will automatically add the "Sender:" header which contains your actual Gmail address. (Outlook displays this as "via" I believe.)

The only way to avoid that is to have the username that you log in with be "[email protected]" rather than "[email protected]".

The easiest way to do that is to use Google Apps for your domain which is free for up to 10 users.

You can still set that up as a "Gmail" account in iOS, but when you send email it will not have the Sender: header added because you are sending from the same account that you use to log in.

The only drawback is that you will have two accounts now in the iOS Mail app, which is (I assume) what you wanted to avoid by using the comma trick in the first place. You'll have to decide which is more important: having one email account in iOS (and having "via"/Sender: header added), or not having Sender: added and having more than one email account.)

  • So, how does that help setting up my domain as Google Apps then? Won't it show "via domain" anyway?
    – ozke
    Dec 15, 2011 at 10:28
  • I edited my answer to explain more clearly, since I couldn't do it in the space provided here.
    – TJ Luoma
    Dec 15, 2011 at 22:09
  • Hi, thanks for your explanation, it's great. However, what I want to avoid is not the use of the comma trick but the "via XXXX" in Gmail. I believe your solution does not solve that. I am not sure anymore if it's even possible to do easily. :S
    – ozke
    Dec 16, 2011 at 9:27
  • What I have tried to explain is that you cannot use "the comma trick" and avoid the "via XXX" in Gmail. It is impossible. The only way to avoid it is to use the method I have outlined, otherwise you will have the Sender/"via Gmail" line added. There is no other workaround.
    – TJ Luoma
    Dec 16, 2011 at 10:15
  • Sorry, I probably didn't stress enough the importance of keeping all e-mail in a unique interface. As I said in the question, the @owndomain.com it's a forward only account. So what I am thinking now is... maybe redirecting all e-mail from the Google Apps account to Gmail. However, that creates duplicated e-mails, on the iPhone too. ¿right?
    – ozke
    Dec 16, 2011 at 14:32

You would have to set up an alternate sender address via mail.google.com and provide the smtp server of your domain. Set the alternate address as your default address.

Then on your iPhone open the google sync settings page, log in, and check the option to send via alternate sender address.

  • I tried but that will still show the "via XXX" message though... right?
    – ozke
    Dec 16, 2011 at 9:29
  • This is another way of saying what I have suggested in my answer. The other SMTP server would have to be Google Apps as your domain or another SMTP server.
    – TJ Luoma
    Dec 16, 2011 at 10:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .