1

This happened today, and I am writing this in case someone else have the same issue.

I have a corporate MAC, have separate password for Corporate and local password for the MAC.

Everything was fine, today the password stopped working, I was sure it is the password, won't work.

What didn't work...

  1. Single User Mode -> Setup Assistant -> New User -> Login as new user -> sudo passwd <myusername>. Threw an error about authentication method not acceptable.
  2. Tried to reset from Users and Groups. The Reset Password button was not even there.
  3. Tried entering wrong password multiple times to trigger Apple ID reset, nothing.
  4. Command+R for Recovery mode didn't even take me to Recovery Mode.

Machine Specs: MacBook Pro (Retina, 15-inch, Mid 2015) macOS High Sierra Version 10.13.6.

  • 1
    hey, just for our reference, what OS and machine model (eg: macOS 10.13.6, MBP) are your running? -- just so we have everything properly documented here. – bret7600 Sep 20 '18 at 15:39
  • 1
    @bret7600 Updated question. – ATOzTOA Sep 20 '18 at 18:49
2

So, here is what worked!

  1. I went to Directory Utility.
  2. Directory Editor
  3. Compared the Authentication Authority for working user and locked user.
  4. Noticed this new entry on the top: ;LocalCachedUser;/Active Directory/xxxx:5D79515xxxx3B24B.
  5. Removed the entry and rebooted.

Voila, everything is working fine!

  • 1
    I would not recommend this solution. It looks to me like your account is defined in Active Directory, and the authentication problems are coming from AD (i.e. your AD password changed, account got locked, whatever). The problem still exists in AD, and you will not be able to use domain resources until you fix it. But once you do fix it, you're likely to have ongoing problems because your account is no longer properly tied to AD. My recommendation: fix the root problem with your account in AD, and put the Authentication Authority entry back. – Gordon Davisson Sep 20 '18 at 19:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .