3

When I try to type a minus character (e.g. open -a TextEdit) in the MC subshell, instead of minus the Unselect dialog pops up.

Trying to type - into the command line

I'm using iTerm2 and Midnight commander via Homebrew.

1

You need to edit ~/.config/mc/ini config file and look for only_leading_plus_minus entry. By default it is set to false which causes this behavior. If you set it to true

only_leading_plus_minus=true

then - will trigger Unselect dialog only if - is the first character you type which pretty much would never be a problem. If you do not have only_leading_plus_minus just add it. Make sure you do not have Auto save setup enabled in your config and if you do, quit all instances of mc prior editing your ini.

  • I have been waiting ages for this. Many thanks. How did you discover this? – brablc Apr 9 at 13:23
  • 1
    Ha, i knew that despite question being bit old there is a chance you still struggling with that :) I was desperate to get this disabled (as it's annoying AF) and even to dig in the source codes but luckily decided to check the man page for mc first and found "special setting" section - worth checking. Here's online version linux.die.net/man/1/mc – Marcin Orlowski Apr 9 at 15:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .