0

I have 2 MacOS, and 2 iOS devices on the same iCloud account. All but one of the MacOS computers sync Contacts apparently correctly. The one MacOS synchronizes the Contacts but no Groups are brought over. I've tried everything:

  • reboot all devices
  • Disconnect the problem MacOS from iCloud, reboot, reconnect it
  • Disconnect all the devices from iCloud, and back again
  • Checked iCloud on the web and seen the groups are there
  • Added a group to iCloud on the web and see it appear on the iOS devices and the working MacOS but not on the problem MacOS

Anyone have any other idea that I could try?

  • Did you ever manage to solve this issue? I have the same happening on a new macOS Mojave machine. After logging into iCloud, all of my contacts from iPhone, iPad and my previous Mac appear on this new Mac, but none of the groups. I also tried most of the troubleshooting steps you mentioned, but no luck :-( – Thomas Fruin Jan 21 at 16:48
  • Yes eventually I think disconnecting everything from iCloud, rebooting, waiting 10 minutes and then reconnecting. But that might have just been a placebo, who knows, the problem might have been with iCloud itself. – pitosalas Jan 21 at 16:50

You must log in to answer this question.

Browse other questions tagged .