0

I have this crash on Preview and TextEdit happening every time I use the Print command. cmd+p = spinning ball... It's only on these two apps, as far as I know. Ie: Mail app prints fine. Both MS Office and Acrobat Reader print okay.

Printed installed: Canon MF4360-4390 using driver Canon MF4360-4390 UFRII LT (UK); version 2.0

Current OS: 10.7.2

On 10.6 it worked fine. I already deleted the printer and installed it again but got the same result.

Thanks for any help.

  • Can you post the crash logs here? Just pick the newest crash log for each app. They should be in ~/Library/Logs/CrashReporter/ – bneely Dec 14 '11 at 19:15
  • Force quitting Preview doesn't generate a crash log in that directory - checking through Terminal. Would you like to read the crash report that pops up? Thanks again. – Hugo Dec 26 '11 at 12:38
  • I was out for the holidays too! Post what you have and I'll see if it indicates anything, or if we need to look elsewhere. No promises, though. – bneely Jan 3 '12 at 9:18
  • I just crashed Preview with cmd+p. The crash report exceeds the number of available characters here, so I put the text here: pastebin.com/Sw4Z5keQ – Hugo Jan 4 '12 at 12:36
  • Ah. That's technically a hang and not a crash. The info there makes me think that Preview is stuck waiting for a response from a separate background process. I can't do much more for you on this issue; you should report this at bugreporter.apple.com . – bneely Jan 4 '12 at 20:56
1

My Preview on Lion was crashing on Print. The stack in the crash log shows:

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   jp.co.canon.bj.print.v710a.pde.QualityMedia 0x060b52ae CBJ_SetDispValue(BJPDEMainContext*) + 44
1   jp.co.canon.bj.print.v710a.pde.QualityMedia 0x060b4820 CBJ_QualityMediaPDEPluginFactory + 1064
2   com.apple.print.framework.Print.Private 0x0654f709 0x6537000 + 100105

I tried upgrading to the most recent drivers from Canon's MX850 page. No luck.

I opened "Get Info" from the Finder, with Preview selected, and saw I had set it to "Open in 32-bit mode". I unchecked that box. Now Preview prints again.

  • Mine is unchecked. I checked the 32-bit mode, tried and crashed. Back to unchecked mode and it's still crashing. Thanks anyway. – Hugo Jan 13 '12 at 9:45
0

Found Canon's response to this bug on 10.7: http://www.canon.co.uk/Images/Mac%20OS%20X%2010.7%20printer%20driver%20compatiblity%20issue%20and%20recovery%20procedure_tcm14-852700.pdf

I also found that they issued a new driver a few weeks ago, so everything is OK. Preview is rocking again! http://software.canon-europe.com/

Thanks everyone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .