1

I have an iMac running High Sierra 10.13.6. I tried to use Google Earth a few days ago and I got an updated software message. I followed the instructions and downloaded a .pkg file. When I run the file, it appears to run normally as far as I can tell. But when it finishes the installation I get the following screen:Failed Installation notice

I thought maybe I had a virus so I tried running Malwarebytes. I got another upgrade notice so I downloaded the new version. It turned out to be another .pkg file. I ran it and it too seemed to be working fine but again I get a screen like this:

Failed Installation notice

Can someone explain what is going on? A remnant of the Google Earth failed upgrade is that I keep getting a message on my screen that looks like this:

Sh error message

This banner appears about every hour or so. While it doesn't cause problems it is very aggravating to see this continually popping up. Any help on these issues would be appreciated.

I have looked for answers elsewhere but no luck. I've restarted my machine in several different modes but nothing seems to effect this. Am I doing something wrong, or is my computer screwed up some way. Thanks in advance for any help you can give me.

  • Take a look at this Apple page and see if this helps. It appears that the Google Earth updater is not really a .pkg file. If those comments help, I can add it as an answer. I'm not sure it will solve the problem so I didn't add as an answer yet. – fsb Sep 19 '18 at 19:08
  • did you have Google Earth Pro ? – Ruskes Sep 19 '18 at 19:34
  • see this google.com/earth/download/gep/agree.html – Ruskes Sep 19 '18 at 19:35
  • Thanks for the link. There is a lot of info there and I'm going through it all. It definitely sounds like my problem. – jmh Sep 19 '18 at 19:36
  • 1
    I have Etrecheck. I'll run it now. – jmh Sep 19 '18 at 20:16

You must log in to answer this question.

Browse other questions tagged .