1

Samba recently added the ability to host time-machine backups over a local network with version 4.8. I set up an old Seagate goflex with Arch linux and followed this guide to get samba running. It's working except that every time a backup is started on either of my two laptops I get a warning that "The identity of the backup disk “ArchBackups” has changed since the previous backup." and have to click through. Any idea why my mac isn't trusting the backup server? There is this old question but that seems to be a more intermittent problem on an older version of OSX and never got a satisfactory answer.

7
  • Can you show us how you're mounting the drive... i.e. /etc/fstab entry?
    – Seamus
    Sep 19 '18 at 17:39
  • The drive is formatted as LVM and my /etc/fstab is /dev/mapper/backupVG-backupLV /backups ext3 defaults 0 2 /dev/mapper/backupVG-swap none swap defaults 0 0
    – pgcudahy
    Sep 19 '18 at 18:07
  • If I understand this correctly (and I'm pretty sure I don't), you have an ArchLinux host running Samba to share the Seagate (?) drive that you've configured as an LVM... is that correct? If so, perhaps it's the LVM layer that's creating the confusion in that LVM isn't a specific device? But honestly, that's a WAG as I know nothing about LVM - or why it's needed in the role of a TM surrogate.
    – Seamus
    Sep 20 '18 at 16:32
  • The Seagate is a cheap NAS that comes with an embedded linux os. I wiped that and installed Arch instead. I wanted the ability to add more drives in the future so I formatted the single drive as Ext3/LVM.
    – pgcudahy
    Sep 20 '18 at 16:44
  • OK, so why LVM rather than as a single drive? I don't recall the tutorial you followed specified that. LVM just seems an odd choice to me in this situation.
    – Seamus
    Sep 20 '18 at 18:22
2

Edit: Find my solution below.

I have the same problem on Raspian with a Ext4 file system (no LVM). Samba is version 4.8.5, compiled from source by myself. MacOS is High Sierra, backup is encrypted.

Time Machine pretends to have finished the backup successfully. When it starts the next time, the message about the changed identity appears. After choosing "backup anyway", it creates a completely new backup in a new sparse file. (Like @thaimin described it).

On the Samba mailing list someone states:

Recompile samba with --enable-spotlight and all works.

That is not true in my case, because I did compile Samba 4.8.5 with this option (what I didn't do is setting up tracker as suggested in this blog post).

Workaround

I compiled Samba in the previous version (4.8.4). Now it works as expected (same system, same dependencies, same configuration).
Someone already created a bug ticket for Samba.

1
  • Yes, it seems to have been a bug with samba 4.8.5. I just upgraded to 4.9.2 and the problem has resolved itself.
    – pgcudahy
    Nov 25 '18 at 17:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .