6

I created some simple Shortcuts in the new iOS Shortcuts app (iOS 12) to be invoked by Siri.

Like: "Goodmorning Siri, start my morning routine" and then some actions.

Now I also would like to let Siri say some things to me, as simple as: "Hello Jeroen, I hope you have a good morning".

I am supposed to use the "Show result" actions for this, this action should result in spoken feedback if the shortcut is executed via Siri.

The problem is: "Show result" text is not spoken (Siri feedback) by Siri when the shortcut is invoked via Siri. Actions that come after the Show Result action are executed.

Here is an example Shortcut:

enter image description here

I tried already:

  • turning Siri on and off
  • Soft reset
  • Reset network
  • Change Siri and iOS language

Update: I have a iPhone SE

  • 1
    Is Siri showing the result but not giving an audio ouput, or is it showing no result at all? – npkllr Sep 19 '18 at 9:12
  • 1
    No textual or audio feedback at all. – JeroenVdb Sep 19 '18 at 10:27
3

Shortcuts allows for this, but not with the default Siri voice.

In order to add speech into your Shortcut, you need to add two objects into your script.

First: "Text". Second: "Speak Text".

The following screenshot should help. Alter the contents of the Text box to your liking, and tweak the language, speed and rate to your liking in Speak Text. Hope this helps! Text followed by Speak Text

0

Seems others are having a similar issue. Over in r/shortcuts, there's an indication that to achieve what you want, you must use both Speak Text and Show Result. It could be a bug, or it might be limited to particular devices.

https://www.reddit.com/r/shortcuts/comments/9mo0qe/which_network_help_with_speak_text_show_result/

0

I was having a similar issue and I had to add an "open in = shortcuts app" action at the beginning, so that when the Shortcut runs (either via widget or invoked by voice via Siri) it would be spoken out loud by Siri. I'm not sure if this is the expected behavior but it definitely worked for me :)

  • Doesn't work for me. Siri still simply says the task is done but gives no further result. – Tum Oct 24 '18 at 13:29
0

I have the beta program, and it works fine. It's likely just a glitch they are planning on patching in their next update.

-1

Hey Jeroen check here...

https://talk.automators.fm/t/show-results-only-give-me-a-text-alert/2025

guess it might solve your problem...

  • Welcome to Ask Different and thank you for your answer. :) Unfortunately, short answers such as this don't really provide enough detail or context to help many users. And, just providing a link isn't very helpful as it may no longer work in future. Instead, could you please edit your answer (there's an edit link below it) to include a summary of the content you're linking to? This will make your answer more self-contained and help preserve it for other users in future. – Monomeeth Sep 20 '18 at 1:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .