4

OK, so I've installed iOS 12 on my iPhone 8, and watchOS 5 on my Apple Watch series 3, everything is paired and set up.

I have created a custom shortcut on my iPhone with the new Shortcuts app. If I hold the Home button on my iPhone and speak my custom phrase, the shortcut runs successfully.

However, if I hold the crown on my Apple Watch, and speak the same custom phrase, Siri just says it doesn't know this command.

Did I forget to configure support for this? I can't seem to find any settings for this, nor does it seem that I should install Shortcuts on the watch itself.

I've checked in the shortcuts app itself, in settings, in the watch app with the settings for the watch, etc.

Or perhaps Apple did not implement support for this (yet)?

1

I just tried some of my shortcuts, and they work perfectly fine on my Apple Watch.

However according to Apple:

Shortcuts that require an app to open on your iOS device might not work on HomePod and Apple Watch.
(Source: Use Siri Shortcuts)

So maybe that is the reason your shortcut works on you iPhone, but not on your Apple Watch.

  • I tried the following. I created a new shortcut that sends my own phone number an SMS, I disabled the show checkbox (it's in norwegian but translated to "Show when executing"). I then added a siri command to it, gave it a name and saved it. I then hold home button on phone and say the phrase "Test", it says (agan, Norwegian) "Executed", and a message is received. I then try on my phone and it says (Norwegian) "I do not recognize this command". Not sure what else I can do. – Lasse Vågsæther Karlsen Sep 19 '18 at 10:18
  • I'll try reconfiguring both devices to english and see if that helps, though the phrase "Test" is the same in both English and Norwegian. – Lasse Vågsæther Karlsen Sep 19 '18 at 10:18
  • 2
    I ended up unpairing the phone and watch, did a full reset of the watch, and this was, well, 50% successful. After pairing and setting everything back up, the watch seems to accept the commands, but then it says that it will let the shortcut app take over the command, and then ... nothing. I guess this isn't all that finished :) – Lasse Vågsæther Karlsen Sep 19 '18 at 15:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .