I am on OS 10.13.6 in High Sierra. I just updated from Xcode 9.4.1 to Xcode 10. It now opens the application and instantly quits without me being able to do anything. I am unable to open any projects, playgrounds, files, or even the application itself without it instantly quitting.

Based on these posts: Xcode doesn't start, XCode Hangs at Startup, and https://discussions.apple.com/thread/3830815, I have tried the following, but nothing has worked.

  1. Restart my computer
  2. Delete Xcode 10 and redownload from the App Store
  3. Delete Xcode 10 and redownload the .xib from developer.apple.com
  4. Delete Xcode 10 and redownload Xcode 9.4.1 from developer.apple.com
  5. Delete ~/Library/Developer/Xcode
  6. Delete my Xcode preferences from ~/Library/Preferences

After updating to Xcode 10, something must be corrupted as I can no longer open even Xcode 9.4.1.

I have not tried to use a guest user yet as I would like to keep all my projects on my profile. What are other possible solutions to try and get any Xcode running on my computer(, but preferably Xcode 10)?

  • I am facing the same issue. @Gerald did you solved this? – hannanessay Oct 10 '18 at 7:17
  • was this ever solved? – Shayne Dec 19 '18 at 14:35

You must log in to answer this question.

Browse other questions tagged .