3

Since installing Safari 12, I've been unable to get my extensions working. In particular I have no functioning ad blocker, and the primary extension I use, Pocket, (rally the only reason I use Safari at all) doesn't seem to work. In order to prevent Safari from showing repeated warnings each time I launch it, I've cleared out my extensions and emptied ~/Library/Safari/Extensions/.

How do I get and ad blocker and Pocket working with Safari 12?

  • It may be that the developers of Pocket need to update their code to be compatible with the new Safari. I know I had to update a few extensions for them to work properly. – Steve Chambers Sep 18 '18 at 19:00
  • @SteveChambers Are there any ad blockers that work with Safari 12? Ads are a show stopper, an even a few hours of them will likely drive be permanently to Chrome, so I'd like to get that fixed fast. Ad Block Plus claims to work, but Safari won't let me adjust its settings even after (apparently) successfully installing it. – orome Sep 18 '18 at 19:03
  • Try Ublock origin. Also sixcolors.com JUST published a way to make extensions that no longer work now function properly... – Steve Chambers Sep 18 '18 at 19:18
5

The latest Safari update (12.0, Sept 17, 2018) turns off some and and stops supporting other extensions.

I don't see Pocket on Apple's new list of supported Safari Extensions (https://itunes.apple.com/us/story/id1377753262). That might be why Pocket now recommends that Mac users just use their Mac app: https://help.getpocket.com/article/1042-using-pocket-for-safari

Pocket may update their extension such that Apple starts supporting it again. Until then, there might be a javascript bookmark(let) for saving items to Pocket (https://support.apple.com/en-us/HT4550) or a Pocket email address to which you can send items to your account (https://getpocket.com/add/).

Update: Some unsupported extensions work again in Safari 12. E.g.,

-1

I loaded Pocket from here and it seems to work with Safari. I use the ad blocker "Ka-Block!" and it appears to be working... So load Pocket and use Ka-Block and they work together on my machine.

  • why the down vote! it answered the question.. – jmh Mar 6 at 14:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .