1

Here's how to reproduce this:

  1. Installed VLC via: brew cask install vlc*
  2. Open VLC (via Spotlight/Finder/open/something else using launchd**)
  3. Finder alert dialog pops up with message:

    The application “VLC.app” can’t be opened.

This has never been a problem until I installed the latest version. I'm guessing it's more something to do with launchd than VLC (my other MacBooks are all fine).

How can I diagnose what's failed and/or make this app launch again?

* makes no difference downloading with browser).

** I'm able to start it via: $ /Applications/VLC.app/Contents/MacOS/VLC, so I am guessing it's something to do with what is launching it.

  • "something else using launchd"? What does that mean? Have you tried reinstalling VLC or downgrading to an earlier version? Why would you assume launchd is the culprit when the thing you changed was VLC itself? – Allan Sep 17 '18 at 15:26
  • @Allan I meant something else that leverages launchd to start the process. I was under the impression that when I start the mach-o binary (instead of the .app launcher) from a shell (see asterisk comment above) that it would not be handled via launchd? (I'm guessing I'm wrong on this please correct me if so, any links/reading would be appreciated.) Yes I have tried downgrading to every version of VLC 3.x.x and I seem to be getting the same issue. – rounce Sep 17 '18 at 16:53
  • VLC media player is available without the need to use Homebrew. – user3439894 Sep 17 '18 at 17:26
  • @user3439894 Good point, I'll amend the title & question. I happened to install via Homebrew but the VLC formula downloads from the same location (and no, it doesn't make any difference downloading with my browser, why would it?). – rounce Sep 17 '18 at 19:38
1

I don't have the same issue, but before you try to remove the vlc 3.0.4 and try installing an older version, do you have any errors in the doctor output:

brew doctor
brew cask doctor

If not, then an upgrade, reinstall of the VLC and then force linking the app again might help. Also - if you open the console log when you open the VLC app - can you see any interesting or relevant errors right around when you launch the app?

brew upgrade
brew cleanup
brew cask reinstall vlc
brew link -f

Feel free to @ me in the comments if you make a substantial edit or ask a follow on question to review the output of the above if it's not clear how to fix this once you dig in a bit.

  • This was the first thing I tried, before posting, no joy. – rounce Sep 17 '18 at 19:07
  • @rounce Cool, you’ve done all the things short of opening a bug against the package on GitHub for home brew. You’ll need to follow their steps for attaching logs and it might be VLC issue. It’s fine to Ask here, someone is bound to have an answer, maybe even you will have an answer soon. – bmike Sep 17 '18 at 20:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .