Using macOS 10.12.6 on a PowerBook. In the past, I was able to use Mail.app to connect to my @outlook.com account, but after a password change (forced? I don't remember - it's not a primary mail account), Mail.app can no longer connect to the mail server.

The same credentials work on the outlook.com web application. So I decided to delete the account from Mail.app and re-add it. Here's what I saw:

  • Choose Mail -> Add account...
  • I select Exchange and click Continue
  • I enter name/address/password and click Sign In
  • I see this window: the window below:

I am not aware that I made any changes to the Microsoft server. Thoughts? Suggestions? Thanks.

  • Depending on how the server is configured, you may need to include your DOMAIN in the username field. It could be username@domain or domain/username. Check with your IT/mail admin to verify.
    – Allan
    Commented Sep 17, 2018 at 15:28
  • Yes, but... (I believe) this is the URL suggested by Microsoft's own Exchange server (at "outlook.com") Commented Sep 18, 2018 at 16:29
  • I'm seeing the same thing, and oddly enough, I can add this account just fine on my iPhone and iPad. AND it works on this same Mac via Outlook. Commented Sep 18, 2018 at 22:33
  • Bingo! I too can add the account on my iPhone. Sounds like a bug (in the macOS Mail.app) to me. Thanks! Commented Sep 20, 2018 at 0:08

4 Answers 4


I've struggled with this problem for months. My old hotmail account, which I've had since before MS bought it, stopped working on my Mac. Webmail worked fine, iOS worked fine...just wouldn't work on Mac Mail. Finally got it solved today.

If you have 2-step verification enabled on your Exchange account, you can't use your normal password with the Apple Mail client...you must generate an "app password" on the Exchange site, then use that in Mail. NOTE: creating this "app password" does not change your regular email password.

To create an "app password": - log into your Exchange account via the web - click on the "you" icon at the top-right, then click View Account - click Security near the top of the screen - click the "More Security Options" link below the other option panels - scroll down and click on "Create a new app password" - use the resulting app password in your Mail client

  • This worked for me, but my steps were a little different: Click gear icon near top right of Office365 web view > scroll to "Additional security verification" section > Click "Create and manage app passwords" > follow the instructions to create a new app password. After entering the password into Mail I had to restart Mail for the password to take effect.
    – Sean Fahey
    Commented Jan 21, 2019 at 16:00
  • This is ridiculous. I'm going back to Gmail. Commented Jan 8, 2020 at 4:25
  • James...I understand your frustration. However, I think you're going to find that if your gmail isn't already requiring a similar "app password", it will soon. I've been getting emails from Gmail admin indicating that they're in the process of moving to a similar approach to allow third-party tools to access your gmail account.
    – Juber
    Commented Jan 10, 2020 at 0:23

Had the same problem too... use your email address for name, email, and user name.


I've also had issues using my outlook(Hotmail) with mac mail app recently. Kept asking for password then rejecting it(wrong username or password). The server always offline. Spent days googling and trying everything and nothing worked. Eventually, I try using Preferential Treatment app to check for bad plist. Came up with /Users/YOU/Library/Preferences/com.apple.mail-shared.plist as corrupted. Deleted it after closing mail and eventually after a few times trying to re-enter password and other info in server settings and saving and being told account username or password wrong, eventually says account already exists and has started working. Not sure exactly how I did it and for the moment I will leave mail running but seems deleting the plist has helped. Hope this helps and someone who knows what they are doing can work up a proper sequence to fix this issue.

  • This worked for me immediately. I had tried other's suggestions on deleting Keychain entries/rebooting, disabled 2 Factor Authentication at Exchange level, and enabled "All eMail Apps" for the individuals account. Commented Sep 1, 2019 at 23:25

Just to confirm: /Users/YOU/Library/Preferences/com.apple.mail-shared.plist and nixing the plist worked for me too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .