I have MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports) with macOS High Sierra installed. I plugged it in to external display: LG 24UD58 24" via DisplayPort through USB-C

For unknown reason Macbook works at 30Hz instead of 60Hz. I managed to achieve 60Hz once somehow by switching between resolutions in Display settings, but I couldn't reproduce this anymore :(

System Information

Display Settings

How to achieve 60Hz with external display on Mac?

14 Answers 14


I had the same issue for a long time. At first, 60Hz worked. Then something happened and I'd only get 30Hz on my 4K Lenovo ThinkVision 27".

I stumbled upon this article and simply went to Display settings and hit "Resolution: Default for display". Immediately the display switched to 60Hz. Then I could reapply my Scaled text size setting and 60Hz remained.

What an unsatisfying fix!

  • Wow had tried everything else suggested all over the internet and this was the one thing that finally worked! Had this problem with an LG 4K monitor.
    – Harry M
    Commented Jan 21, 2020 at 23:23
  • Same issue, also with an LG 4K monitor. Thanks for your answer!
    – Gabriel
    Commented Apr 6, 2020 at 17:08
  • This also worked with an Acer ultrawide 3840x1600. Thanks!
    – Leo
    Commented May 21, 2020 at 14:21
  • I still get this issue from time to time. Another observation I made is that sometimes just switching the setting once doesn't cut it. Some combination of unplugging the display, powering it on/off and playing with this setting always solves it eventually. It can be a real pain though. Commented May 22, 2020 at 16:40
  • I had this issue happen a couple days after installing an IOGEAR KVM to my Acer monitor, and this fixed it! Wish I could upvote twice! Commented Sep 2, 2020 at 0:43

Try EasyRes app from the app store. One of my 4K monitors get 30Hz when I connect 2 4K monitors to my MacBook pro. The 2 monitors works fine together on Windows. Apple Support doesn't help. EasyRes fix the problem with 1 click.

Given that all hardwares are capable (monitor, computer/GPU, cable).

  • 2
    I had this problem as well on an iMac with a 4K external display. With EasyRes it was immediately solved. Much appreciated!
    – 0xDEADC0DE
    Commented Oct 22, 2020 at 7:35
  • Ok, EasyRes solved my problem immediately. None of the other solutions worked for me.
    – superiggy
    Commented Jul 23, 2021 at 20:30
  • What a nice application. While it fixed the 30Hz issue, when I set it to 60Hz everything was so blurry I had to revert it back :( Commented Oct 24, 2022 at 18:22
  • EasyRes solved my problem, thanks!
    – cspinetta
    Commented Nov 7, 2023 at 9:32

I'm here to offer a different solution. I have a MacBook Pro 15(2018) connecting with LG Ul500 27'4k monitor. I met the same issue that the external monitor worked on 60hz at the beginning but changed to 30hz one day. I thought there might be something wrong with my cable, so I changed it with one of higher quality and price. But the situation didn't change. Then here comes the solution.

I enter the menu of my monitor and tried to reset it to the initial settings. Boom. Problem fixed. It's working on 60hz right now.

  • 2
    Similar to mine Lenovo T27p-10. Easier solution: reset USB3.0 -> USB2.0 (2.0->3.0 didn't help). Then "Default for display". 60Hz voila! Similar thread: forums.lenovo.com/t5/Displays-Options-and-Accessories/… Commented Jan 12, 2021 at 17:26
  • 2
    On my asus monitor I had to do a similar thing, I went to saved presets/favourite and I chose a blank one and it worked. All the other suggestions I've found didn't work so thanks.
    – Danny
    Commented Jul 28, 2022 at 9:53

The Mac should automatically set itself to 60 Hz when available. Otherwise you can select 60 Hz from the drop-down titled "Refresh Rate".

In your screen shot that drop-down is greyed down, because it only has one option (30 Hz). This means that the Mac has not detected that the cable and monitor are cable of 60 Hz refresh rate.

As the monitor supports 60 Hz and your Mac does so as well, all points to the cable. Please try again with another cable, and make sure you buy a quality cable that supports bandwidth enough for 4k @ 60 Hz.

  • Yes, either the cable has an internal break or one or more of the pins are damaged or not connecting. Check for dust but cable probably.
    – Solar Mike
    Commented Sep 17, 2018 at 11:58
  • Thanks. I was sure I bought quality cable :( It was specified it supports 4K @ 60Hz Commented Sep 17, 2018 at 11:59
  • Yes, unfortunately the cable market is a real jungle. I have tried before buying expensive display cables on the high street for connecting 4k@60 Hz and found them not working - replaced it with a cheap cable from IKEA (!) and it just worked.
    – jksoegaard
    Commented Sep 17, 2018 at 12:16
  • @LawrenceWagerfield Your comment does not make sense in so far as claiming that the original answer is incorrect. The original answer and the comments below are from 2018 describing the situation with High Sierra. You claim that this was all caused by Big Sur - but Big Sur didn't exist at that time. Big Sur was released in November 2020, so it could not have been the cause of display issues in 2018.
    – jksoegaard
    Commented Feb 2, 2021 at 12:24
  • Apologies @jksoegaard -- this question has been linked in a recent thread over on Apple Support as containing the solution for Big Sur -- I hadn't read the dates and assumed all the discussions were relating to the recent changes in Big Sur! I shall delete my comment, as you're right: the comment doesn't make sense in the context of the issue people were facing in 2018, Commented Feb 2, 2021 at 14:41

Okay, so I used another USB-C port and it worked! Apparently the right front port in my laptop doesn't support 60Hz, I don't know why


For BigSur 11.x (I'm on 11.6), my display was on HDMI 2.0 UHD but BigSur was pumping out at 30 Hz. I couldn't find any other option BUT this worked

Go to system prefs -> Display -> CMD+click on the "Scaled" radio box to see hidden UI options. Enable "Show low resolution modes" > to see the resolutions I could select there was another check box for "Show Low resolution modes". Now the hidden "Refresh rate" drop down should appear. Select 60 Hz :)

enter image description here

  • 1
    Worked for me! Except, in macOS 12 Monterey, I needed to use option instead of command when clicking the Scaled radio box. Bizarre hidden functionality.
    – jorisw
    Commented Oct 26, 2021 at 12:50
  • For me it only allows me to select 60Hz when choosing a "low resolution" option. MacOS Sonoma 14.5, a i-tec dongle and Benq monitor Commented Jul 2 at 11:43

Adding another solution: I have 2019 MBP with four thunderbolt ports, and a Levovo LEN T27p-10 monitor which seemed to work only 30Hz.

60Hz starts towork if I switch USB Source Selection in the monitor settings from USB 2.0 to USB 3.0, and then back to USB 2.0 again. If you already had it as USB 3.0 just switching to USB 2.0 is probably enough.

I need to do this every time the monitor shut down from the power button. Mac sleep mode doesn't seem to trigger the problem.

Annoying, but at least I finally found a reliable workaround.


I had this problem with a different brand of display. I resolved it by changing the Display Port Version 1.1 to 1.2 in the monitor's on screen display menus.

  • Thanks! That's not my case though. DisplayPort 1.2 is enabled in settings. Commented Feb 19, 2020 at 14:44

I also had an issue where I have three 4K monitors setup to a MacBook Pro and at one point my left most monitor switched to the Resolution setting "Default for Display" (I normally always have them set to "Scaled" and have the middle option selected").

I then changed the resolution to Scaled and chose the middle option to match the other two monitors. Upon doing so, the monitor went into 30Hz mode and I got a laggy mouse. The thing that worked for me was change the offending monitor back to "Default for display" and then do that for the other two monitors. Next, I went to the left most monitor and I set the resolution to Scaled again (middle) and then I did the same for the other two monitors and everything went back to normal; all three monitors were now at 60Hz!


I am using a Samsung LU28R55 as external display with my 2020 13" MacBook Pro.

I have been suffering from the same problem (external display running at 30Hz, no matter the resolution). Interestingly, switching the external monitor's resolution to "Default for display" had no effect.

I had to do it for both the external and the internal display (I run pretty high resolutions on both). Then both displays switched to 60Hz and everything has been working fine since then.


I'm using MacBook Pro 2019 with Asus PA278CV ProArt monitor which supports 75 Hz (2560x1440).

I have noticed one important thing that you also need to keep in mind - if you're using only one USB-C cable to connect your laptop and monitor it's important to understand how much power your monitor can deliver via USB-C cable.

In my specific case my monitor can deliver only 60 W - so that's enough only to run monitor at 30 Hz! When I have connected OEM charger to the laptop and reboot it again - 60 and 75 Hz options were available. So check if your laptop has enough power to run the monitor at high Hz.

  • How can this be checked?
    – nohillside
    Commented Jul 3, 2022 at 5:50

If you're a victim of Apple and forced to use dongles, then check your dongles. My dongle was not capable of running display on 60Hz.. only on 30Hz. Had to get usb-c <-> Display Port connecter to get 60Hz.


I was able to resolve this issue on my 2018 MacBook Pro by getting rid of my HDMI cable which was connected via dongle/adapter and switching to DisplayPort which is connected directly via USB-C.

In my case this means the issue could have been:

  1. The quality of my HDMI cable, but I tried 2 before switching the setup
  2. The adapter itself, however, I also tried 2 before going to DisplayPort
  3. The Mac in this case could just be playing nicer with DisplayPort

My experience was the same as Michael Trojanek's. Once I got a USB-C adapter for the Display Port, the 60 hz kicked in.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .