I had to make a bootable macOS High siera install, everyhing went well and it worked. I'm trying to remove the app that I used to install it and trash won't let me. Everytime I try I get an

The operation can’t be completed because the item 
“Install macOS High Sierra.app” is in use.

error. I tried to circumvent this by option+click and selecting "Delete immediately" but that just gives me an

“InstallESD.dmg” can’t be modified or deleted because it’s required by macOS.

error. Any help for getting this thing off my computer will be greatly appreciated.

  • An observation on when this happens: I downloaded the install apps for High Sierra, Mojave, Catalina, and Big Sur. The first three all gave me an error saying that the install app could not be run. Big Sur ran, and I quit it. I was able to delete Big Sur, no problem. But the other three could not be deleted. It seems that the dmg was mounted for those, but when the app failed to run, those dmg's were somehow marked as mounted in permanent way. Even though they don't show up as mounted, where this apparent mark survives a reboot. (This is all on the latest Big Sur, 11.2.1.)
    – Mark Adler
    Feb 11, 2021 at 7:15

5 Answers 5


I was experiencing this problem after downloading High Sierra to fix a friend's Mac. I found Rick's solution worked for me, but I've added a few more steps.

  1. Click the  symbol in the Menu bar.

  2. Click Restart….

  3. Hold down Command + R to boot into Recovery Mode.

  4. Click Utilities.

  5. Select Terminal.

  6. Type csrutil disable. This will disable SIP.

  7. Press Return or Enter on your keyboard.

  8. Click the  symbol in the Menu bar.

  9. Click Restart….

Extra Steps

  1. Log in / boot up the Mac.

  2. Empty Trash.

I also found that somehow Previous System folder appeared under the Mac HD. So I also trashed that (which wouldn't trash previously).

I then rebooted the Mac a few times to check that everything was working fine. Then rebooted into recovery mode.

  1. Hold down Command + R to reboot into Recovery Mode.

  2. Click Utilities.

  3. Select Terminal.

  4. Type csrutil enable. This will enable SIP.

  5. Press Return or Enter on your keyboard.

  6. Click the  symbol in the Menu bar.

  7. Click Restart….

  • You don't need to reboot with SIP disabled, see other answer.
    – MarcH
    Mar 27, 2019 at 21:59
  • I just used this answer to remove a Mojave installer that would not delete from a Big Sur OS. I had created a bootable installer for Mojave that somehow stayed around and would not delete. Thanks.
    – armand
    Dec 10, 2020 at 8:28
  • @MarcH Yes you require to reboot with SIP disabled
    – alper
    Sep 18, 2021 at 12:05
  • This answer disables SIP. I followed Martin B's different answer and it worked without disabling SIP.
    – MarcH
    Sep 21, 2021 at 5:27

Fastest way to fix this is the following.

  1. Reboot
  2. Hold Cmd + R
  3. Choose language
  4. If you are using an encrypted disk, select "disk utility" then select the disk where the unremovable files are located, and mount it. Once this has been mounted, quit disk utility.
  5. In the Utilities menu select Terminal
  6. Type cd .. as many times that are needed until you can see /Volumes
  7. Type ls to see if you are where /Volumes is present
  8. Type cd Volumes
  9. Type ls to see name of harddrive
  10. Type cd *nameofharddrive*/Applications
  11. Type rm -r Install (press tab to write out the whole filename)
  12. Press enter to delete
  13. Reboot
  • Yes it's much faster however it's missing one step: unlock and mount the encrypted hard drive with "Disk Utility" first before opening a Terminal. Cause you're not crazy enough not to encrypt your hard drive, right? :-)
    – MarcH
    Mar 27, 2019 at 21:58
  • This worked for me. I was able to just type cd "/Volumes/Macintosh HD - Data" after mounting the Data partition of my hard drive.
    – hrunk
    Jan 7, 2022 at 22:01
  • This method still works on macOS 12.6 Monterey (which saved an extra reboot to disable/reenable SIP). The method below ("2. Re-download respective installer [...] overwriting the broken installer") did not work on Monterey.
    – tompark
    Jun 23 at 21:30

I have found another solution in case rebooting in Recovery mode is not an option for you.

  1. Move the offending Mac OS X installer back from Trashes to Applications

  2. Re-download respective installer (e. g. the High Sierra using AppStore from https://support.apple.com/kb/HT208969) overwriting the „broken“ installer with a fresh one fixes the permission issue.

  3. Drop the installer from Application to Trash. Empty trash will work now, deleting the installer correctly.

  • 2
    Excellent solution. While I hate wasting time/bandwidth on a 5+ GB download, this was much easier than trying to restart in Recovery mode as the computer in question was remote and I was VNC'd in! Jul 5, 2019 at 14:45
  • Excellent! Works with macOS 10.14.6 Sep 8, 2019 at 8:54
  • Did not work for me (currently running Big Sur, the installer app for High Sierra's been stuck on my drive for a while though).
    – ash
    Nov 28, 2020 at 19:44
  • Did not work on Big Sur (stuck with a High Sierra installer...)
    – BjornW
    Mar 14, 2022 at 21:59
  • Indeed, this hint does not work in Big Sur anymore. I've ended up moving the bad file to iCloud storage, it will hopefully be deleted as unused.
    – igraczech
    Mar 16, 2022 at 15:14

What happened was the installer was getting caught by Mojave's system update panel in the system preferences.

Just had to disable SIP and it deleted okay with no issues to the computer after.

  • 1
    What is a SIP? I really don't know. Can you make this a bit easier to apply (for others, too!) as an answer?
    – esaruoho
    Nov 19, 2018 at 0:02
  • SIP is System Integrity Protection. You really should not disable this, other solutions are much safer. But here's some more info anyway: developer.apple.com/library/archive/documentation/Security/…
    – Aron
    Jul 18, 2019 at 15:31

I ran into this recently on a machine running macOS Mojave (10.14.x), where I was running low on disk space, and still had this installer.

The built-in Storage Management application should allow you to find the item in the Applications panel and you can delete it from there. I personally found right-clicking on the item and selecting Delete to be more responsive than selecting it and using the button.

Accessible on Sierra and later by:

  1. Apple icon > About this Mac
  2. Storage tab > Manage...
  3. Select the Applications tab and find the item in the listing
  4. Right-click on the item and select delete, or select the item and use the Delete... button.

Disabling Systems Integrity Protection (SIP) was not required, nor was a reboot.

  • There is no built-in Storage Management application on my system. Are you sure you didn't download it from somewhere? Jul 5, 2019 at 14:28
  • 1
    Updated the answer to link to Apple support and include the actual steps. I'd be interested in whether you still can't see it as I am on two different computers. Jul 7, 2019 at 15:29
  • 2
    Perfect. I was hunting all over Applications, Utilities, in the disk directory, could not find it. Did not know about the items in the About this Mac menu! A really odd place to put those functions. Totally non-intuitive! Jul 8, 2019 at 11:52
  • Yeah, yeah it is. :) Jul 8, 2019 at 13:51
  • Does not work with macOS 10.14.6 Sep 8, 2019 at 8:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .