3

MacOS: High Sierra 10.13.6

Safari: 11.1.2

After a random amount of time the iCloud tabs button on MacOS Safari becomes disabled, making impossible to rich the iCloud tabs of other devices.

Disabled iCloud tabs button

Of course syncing is enabled in System Settings > iCloud > Safari.

I have been able to workaround the problem rebooting MacOS or logging out and logging in the user, which both solved the problem temporarily until the next random block.

Any advice on how to fix it or how to solve it without terminating the user session?

2

I managed to find an easy workaround which doesn't require to terminate the user session.

  1. Quit Safari
  2. Open Activity Monitor
  3. Type in the search box "safari" to filter the processes list

Activity Monitor

  1. Quit and Force Quit (where required) every user process matching the "safari" search
  2. When the Activity Monitor list is completely empty, open Safari and wait some seconds

The iCloud tabs button should appear enabled again.

  • Finally a workable fix for this annoying problem! I was banging my head against the wall on multiple occasions without finding a satisfactory solution. Thanks a lot for sharing! I wonder if it would be sufficient to just kill the SafariBookmarksSyncAgent. I'll try it out next time Safari fails to sync my tabs and report back then. – anothernode Sep 19 '18 at 13:59
  • If you identify the exact process, let me now. – Daniele Orlando Sep 19 '18 at 15:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .