0

I use macOS High Sierra with a HP LaserJet Pro M12w printer. I can print regularly from macOS applications. However, when I print from lpr, the file remains enqueued with a message asking “Load paper in the manual feed tray”.

Note that the printer has only one tray.

With lpoptions -l I've found:

InputSlot/Media Source: *Manual

Which means the default is Manual, and it is also the only option (there is not an Auto option), so I suppose this is the problem (the other options are reasonable and reflect the current printer settings).

I tried to change that setting from the lpoptions command, but it does not change (probably because there is only one value), while from the UI (for instance from the print dialog of applications) there no possibility of changing the input slot (probably because there is only one option).

I suppose that the problem is generated in the ppd file for the printer, where the are the two lines:

*DefaultInputSlot: Manual
*InputSlot Manual/Manual Feed: "<</MediaPosition 4>>setpagedevice"

I'm not sure if this idea is correct, and I'm afraid of modifying that file.

Any idea on how to solve this problem?

Thanks in advance.

  • It's been a loooong time since I've messed around with lpr/lpd and that was on old fashioned Unix. However, you should first, check that the default paper type on the printer isn't set for Manual Feed. Next, it may be a filter issue see /usr/libexec/cups/filter for the filters used by CUPS. It may be defaulted as manual in there. Finally, try lpr -l <filename> to print it without processing it through a filter to see what the results are. – Allan Sep 13 '18 at 16:54
  • Also, make a backup of the PPD you referenced, modify it and try it out. If it fails, you have the backup to revert to. You can't harm anything and the worst that will happen is the PPD fails - it won't harm the printer. – Allan Sep 13 '18 at 16:57
  • Thanks, @Allan, for your comments and for giving me the courage of modifying the PPD file! I posted an answer, for other people with the same problem, which for now works (even if I do not know if I have done some hidden damage :) – Renzo Sep 14 '18 at 7:44
1

I tried a simple hack that works. Do not know if this is the best clean solution (I have doubts!), however it works for me, at least for now.

I simply removed from the PPD of the printer the following lines:

> *OpenUI *InputSlot/Media Source: PickOne
> *OrderDependency: 10 AnySetup *InputSlot
> *DefaultInputSlot: Manual
> *InputSlot Manual/Manual Feed: "<</MediaPosition 4>>setpagedevice"
> *CloseUI: *InputSlot
  • +1. Glad you got it working and for posting your solution! – Allan Sep 14 '18 at 10:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .