4

Although this question has been addressed at this link, none of the solutions worked for me and they are mostly from several years ago (I tried 3 or 4 of them and left comments too).

The problem I'm having is that the mic input level (in the sound panel of system preferences) keeps decreasing automatically. Each time I reset the audio input level back to 100% my problem is solved. I want to be able to have it just stay put without readjusting.

Here's more detail: I'm using a language learning website that has an interactive feature that allows me to record myself saying a phrase so that it can then check if I've repeated the phrase correctly. But I find that as I'm using this record feature, the input mic level in the system preferences starts to decrease over time. So I end up repeatedly adjusting the mic input level back to 100% and it works well again.

I'm using the Chrome browser on Mac 10.13.6 with a MacBook Pro 2015

2

If you are using Audio application (like Skype) or like yours "language learning website that has an interactive feature that allows me to record myself"

you gave them permission to use your audio, otherwise they would not work.

Most of them have audio adjustment within them self (like Skype), so first look for it in your app you are using.

Microphone is used to send something back to the app. In turn it measures the Audio level and sends increase or decrees to your Mac.

Mac is open to those requests (you gave it the permission).

The only way to stop this is revoke the permission, or check what audio setting the app it self has.

Stopping the Auto gain on your Mac would require application specific monitoring and blocking the audio gain adjustments, which could result in the app not working properly since it might not hear you well.

You also have a tool on your Mac that allows for more control and adjustments.

Applications > Utilities > Audio Midi Setup

| improve this answer | |
  • 1
    Thank you for your response. I posted my own answer before seeing yours, so you can check that for details. Your response confirmed some of what I learned, and I believe points to the source of the problem. Also, you provided a valuable tip by pointing me to the Audio Midi Setup. So I've decided to give you credit for the answer. – Tony M Sep 13 '18 at 18:10
  • @user3439894 and what do you think of the answer ? – Ruskes Sep 13 '18 at 18:17
2

I've found an answer to my question, or at least I've found out enough that I have a working solution. Perhaps my experience will help someone else.

On the right edge of the address bar in Chrome, I noticed a video projector silhouette which when clicked provided access to controls for the microphone on that website (upper right of my image below). enter image description here Further, it has a Manage button which allows you to choose the microphone input source. In my setup there are 2 microphones, one in an external display and one called "Internal Microphone" (built into the Macbook Pro itself). I had been using the "Display Audio" so I decided to switch to the laptop mic. After that I closed and restarted the Chrome browser. I then ran several tests and things worked as desired: the input volume never moved from 100% as it had before.

I then tried switching between the Internal Microphone and Display Audio in the sound panel of the System Preferences. There seemed to be no effect; that is, the input level remained at 100%. I suspect that the setting in the Chrome browser takes precedence, but I'm not sure. In any event, now that it's working so well I don't want to mess with it.

| improve this answer | |
  • Let me give you credit for that answer :) – Ruskes Sep 13 '18 at 18:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .