I have an external LG 27UD69P-W monitor connected (via HDMI) to my late 2013 MacBook Pro, which causes the CPU usage of the Mac to go extremely high (kernel_task > 400%, sometimes much higher even), with the fan running very fast. (The computer is so sluggish that even the cursor does not move smoothly, often.)

Some things I've noted:

  • SMC reset doesn't help.
  • Safe mode doesn't help.
  • GPU usage is very low (almost zero) when monitor is connected. Is this to be expected?
  • Occasionally I can connect the monitor and still have a usable computer (< 50% CPU usage) for 5 or 10 minutes, but that's it.
  • Monitor works fine with another MacBook.

What could be the issue here? A troublesome kext perhaps? Any suggestions?


Here's my system log for when I plug in the screen and a couple of minutes after, while the computer is running sluggish / high CPU usage. Notable are the following sorts of events:

  • kernel Currently unsupported feature requested
  • kernel DisplayPipe Capabilities are not supported on offline Fbs
  • IOAudioStream
  • IOAudioEngineUserClient
  • streamFormat
  • coreaudiod*
  • OSCMultiMonitor
  • tccd
  • coreduetd*
  • com.apple.AmbientDisplayAgent Invalid display 0x1b5671a5

Here's a "normal" system log for a few minutes while the monitor is not plugged in.

  • is that a new problem? did it work before – Ruskes Sep 12 '18 at 4:06
  • @Buscar웃 Same issue since the day I got it... – Noldorin Sep 12 '18 at 4:07
  • take look in the Console log to see what are those 2 doing – Ruskes Sep 12 '18 at 4:13
  • also just try to scale down the resolution for test purpose – Ruskes Sep 12 '18 at 4:19

There has been some unconfirmed reports that the NVIDA drivers that came with High Sierra are not operating correctly.

Suggestion is to get updated Drivers from NVIDA directly.

Some have suggested to change the resolution back and fore to fix the problem.

It also looks like your system is no doing Graphics switching.

Check in System Preference that the Auto Graphic switching is turned on.

Also it could be very useful to us if you copy/paste some 30-50 lines in from your Console at the time when you plug in the external monitor so we can see what is going on.

| improve this answer | |
  • 2
    Thanks for your reply and suggestions. My NVIDIA card is NVIDIA GeForce GT 750M, and I don't see an option for macOS on the driver download page. Windows, Linux, FreeBSD, but no macOS! nvidia.co.uk/Download/index.aspx?lang=en-uk – Noldorin Sep 12 '18 at 17:12
  • 1
    I've tried with with graphics switching on and off; same problem. Here's the log for around the time I plug in the monitor for a few minutes after. (Interestingly this time it wasn't so bad... I got video to play reasonably, albeit a bit choppy. GPU usage was very low again, but kernel_task wasn't too high.) Here's a few 100 lines of logs after I plug it in: gist.github.com/alexreg/b03863cb375b924fe211600aa25fe1fb – Noldorin Sep 12 '18 at 17:30
  • 2
    check this out nvidia.com/download/driverResults.aspx/125379/en-us – Ruskes Sep 12 '18 at 17:39
  • 1
    Ah... "Mac OS X version 10.13.6 (17G65) is not supported with this package. Please see NVIDIA’s website for further driver information." – Noldorin Sep 12 '18 at 17:45
  • 1
    OK, your CPU (kernel) gets flooded with IOAudio problems – Ruskes Sep 12 '18 at 17:54

In reply to your updated and extended question

There is a problem with your Boom 3D

error 18:09:59.938200 +0100 Boom 3D AUBase.cpp:804:DispatchSetProperty: ca_require: inDataSize == sizeof(UInt32) InvalidPropertyValue

That probably leads to the continuous and repeating Coreaudiod and IOAudio

I do not know how to fix it, see Boom 3D support

| improve this answer | |
  • Thanks for the new answer. Unfortunately even uninstall Boom 3D completely doesn't seem to help... could anything else be causing the issue? – Noldorin Sep 15 '18 at 18:13
  • Any thoughts? :-) – Noldorin Sep 16 '18 at 19:29
  • @Noldorin do you still have the Boom showing in the log ? and turn off all your sharing for now. – Ruskes Sep 16 '18 at 20:18
  • ok, so you have Alfred 3 installed, and also have some USB audio connected ? – Ruskes Sep 16 '18 at 20:39
  • Yes to Alfred 3, no to USB audio, as I understand. – Noldorin Sep 17 '18 at 1:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .