1

When trying to copy files to a network drive (external hard drive via Router by way of SMB) from MacBook Pro, I get the following:

Items can’t be copied to “folder name” because you don’t have permission to read them.

I ran ls -@Odeln /Volumes/[folder name] in Terminal and this came back:

drwxrwxrwx  1 0  0  - 16384

I have set all rw permissions for users from my MacBook Pro and on the external hard drive, and I'm still getting the same error.

Has anyone else had this issue and been able to fix it?

SCREENSHOT

  • 2
    Welcome to Ask Different. Now, unless I'm missing something, the message isn't reporting you lack authorization to write to ` /Volumes/[folder name]`, it's that you don't have authorization to read the files you want to copy. I suggest you check on the ownership of those files and edit your question to include that information. – Doc G. Sep 11 '18 at 16:15
  • I guess I'm kind of confused by your question. All I know is when I try to copy items from my local MacBook Pro desktop to the server's folder, I get: 'The operation can’t be completed because you don’t have permission to access some of the items.' I can drag files from the server folder to my local MacBook Pro desktop fine but can't do the reverse. – TechGuy1 Sep 11 '18 at 23:37
  • Aha, so it's a server on the other end... I thought you were trying to copy files to a network-based external hard drive. Take a look at the following, and see if it fits your situation: apple.stackexchange.com/questions/113383/… – Doc G. Sep 12 '18 at 5:15
  • No you are correct. I guess I'm just calling it a "server" because of how I connect to it via the "Go" menu. But yes I am trying to copy files to a external hard drive that is connected to my router and it's giving me the stated error above. – TechGuy1 Sep 12 '18 at 5:28
  • 1
    Oh, you meant it as in "Go --> Connect to Server..." Right. So, to fix the problem we must determine who the system considers the owner(s) of these items: A.) The problematic files on your MBP's Desktop, and B.) The remote folder you want to copy them to. You can find out easily enough in the Finder by highlighting one or more of them and then by either using "Get Info" from the Finder's "File" menu or by typing command-I. At the bottom of each of the Info windows under "Sharing & Permissions" will be a table of names and privileges. Collect the information and add it to your original post. – Doc G. Sep 12 '18 at 11:47

You must log in to answer this question.

Browse other questions tagged .