3

Calendar notifications shows a Snooze button. But notifications from browsers do not.

Is there any way to enable snooze on Browser's notifications too?

  • 1
    Can you please specify what notifications are you talking about? Specifically, notifications from which web app? – Nimesh Neema Sep 10 '18 at 18:00
  • When you visit some select websites they offer notifications per post/follower/subscription. Social media sites and YouTube are commonly known for this feature. – Melvin Jefferson Sep 11 '18 at 18:06
  • @NimeshNeema I mentioned "browser" because i tried Firefox/safari/chrome. – Gabriel Sep 11 '18 at 18:16
1

Safari doesn't give you the option to exactly "snooze" website notifications (because the snooze feature is Siri suggested with that notification), but you can manage them:

  • Stop receiving notifications from a website: Choose Safari > Preferences, click Websites, then click Notifications. Find the website in the list, then select Deny.
  • Change how website notifications appear: Choose Apple menu > System Preferences, click Notifications, select the website on the left, then change the notification alert style and other settings on the right.
  • Stop seeing notification permission requests in Safari: Choose Safari > Preferences, click Websites, then click Notifications. Deselect “Allow websites to ask for permission to send push notifications.” From now on, when you visit a website that can send you notifications, you aren’t asked.

Perhaps when MacOS Mojave goes public we will see that as an option. If not, feel free to join the beta/development team and petition your request for that feature.

In the mean time these options work best.

  • 1
    OK, so there is no such option to snooze. I ended up giving up on the browser and now am using the calendar application. But that might not help with other use cases. Hopefully on the next version it will "just work". – Gabriel Sep 11 '18 at 18:18
0

You could use Add-on for your Browsers like this one for Chrome

enter image description here

https://chrome.google.com/webstore/detail/notification-manager/cpjcbknbblieopkakonjnpedhmnhgggg?hl=en

  • this still forces me to go to the browser. i can't do anything from the notification itself. also it will "delay" notifications, not snooze them as they arrive. sounds like a foot gun :) – Gabriel Sep 11 '18 at 18:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .