3

Maybe someone can help me. Earlier today, I was working on my MBP and it wouldn't read my external flash drive, yet it read it last night before I ejected it. However, today it wouldn't find it. I ejected it and tried in my other MBP and my MBA, and my Windows 10 pc, and all three devices could read it. This led me to believe that my ports were somehow not working so I performed a NVRAM reset, and when I did, the screen went haywire, and I was looping at the login screen, which I have been doing for the last 16 hours. So, I ran a diagnostic on the computer and couldn't find any hardware issues. Not only is my screen jacked up, I can't use my flash drive and I can't access my work.

So, I swapped hard drives with my other MBP and it couldn't detect it, so I swapped them back, and the hard drive showed up on that one however, when I tried to command+R, it won't go to the utility disk. So, I tried going to shift+option+command+R, and finally the globe appeared, and I was able to attempt to recover from my time machine, but once the process started, it stopped and the screen went gray and has been that way for hours.

Now, after I put my hard drive back in my second MBP, it's not reading its hard drive at all. I am getting OS X Base System, and nothing more. My hard drive was working perfectly before I swapped it out, now it's not working at all.

I took both hard drives to best buy to have them tested, and they both are operable and both were cloned. Now, I'm getting the error message that MacOS can't be installed to that volume because it's missing a firmware partition. I don't know what to do now, as both my work and my school computers are inoperable, and I have no idea how to get them back up and running.

Please help me.

1

You Title is bit misleading for me.

Based on your description on what is going on lets try to repair your disk.

1- check the cable connections for firm fit.

2- Start or restart your Mac. As soon as you hear the startup tone, press and hold

Command-S

on the keyboard. Keep holding down those keys until you see a black screen with white lettering. This is called “booting into Single User Mode.” As soon as you see the black screen with white lettering, you can release the keys.

Wait for the text to stop.

The last line should end in root#.

Right after the root# prompt, enter the following:

/sbin/fsck -fy

Press the Return key.

It will attempt to repair your disk and tell you the result.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .