0

I use an iMac running High Sierra 10.13.6. I use the command line a lot and recently its developed a problem. I would use the left or right arrow key to move the terminal cursor along a previous command or line. If I made a mistake in a long line I was typing on the command line I would hold down the left arrow key and the cursor would quickly move along the line until I got to where the mistake was. That has stopped happening. Holding down the arrow key takes a second or more to move a single space. Continuing to hold it down is just too slow. It's much faster now to just repeatedly tap the arrow string. This is very frustrating and time-consuming. Does anyone know what happened? The arrow keys used to work fine. I've tried restarting but that hasn't helped. This also happens in text windows and other applications.

  • it still works on my 10.13.6 – Ruskes Sep 10 '18 at 0:44
  • Yes, this happened well after I updated my system. Thanks. I just included my system version for completeness. – jmh Sep 10 '18 at 0:49
  • does it work in other places like Notes ? – Ruskes Sep 10 '18 at 1:20
  • No, it's very slow everywhere I have tried it. – jmh Sep 10 '18 at 1:24
  • 2 more questions, do you use the build in keyboard, is your system preferences settings "standard" ? – Ruskes Sep 10 '18 at 1:35
0

It looks like your settings in System Preferenceenter image description here Keyboard are off

Move the Delay Until repeat Slider to the right to as fast you like it

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .