1

I have a 2012-ish MBP and I am using it to develop iOS apps using Xcode. This app stops responding relatively frequently, but usually I can just force quit it and open it again. However, this time I cannot Force Quit Xcode, although there is no 'dot' beneath it in the dock, right clicking the icon just shows the 'not responding' message. I have attached a screenshot.

See the bottom right

This is preventing me from shutting down my computer. How can I fix this?

I hope my description is clear enough to make this a good question.

  • 1
    If your goal is just to shut down the computer, have you tried holding the power button down for 10 seconds? That should force the computer to shut off. – fsb Sep 9 '18 at 11:35
  • @fsb I have done it now. I had tried that but it brought up a dialogue asking to shut down normally, which didn't work. Thank you for the suggestion - I didn't realise it would work the second time around. – Ethan Wrightson Sep 9 '18 at 11:48
  • I didn't realize it would take 2 attempts, either :-). Obviously, this will not solve your problem but at least you're able to shut the computer down. – fsb Sep 9 '18 at 12:26
  • Have you tried using Activity Monitor? – Hefewe1zen Sep 9 '18 at 12:51
  • @EthanWrightson Have you tried killing the Dock? – waxwing Sep 9 '18 at 14:56
1

If you don't mind using the Terminal.app, I would suggest trying:

sudo shutdown -h now

(-h is for 'halt')

That should shut the computer off as cleanly as possible, and is better than holding the power button down.

If you want to reboot instead of shutting down, try this instead:

sudo shutdown -r now

n.b. This assumes you have an administrator account. You will be asked to enter your login password when you use sudo.

  • I love Terminal! I didn't think to do this because I generally avoid the command - it makes some of my applications angry the next time I start up my computer. Using it won't damage my hard drive or anything, will it? – Ethan Wrightson Sep 15 '18 at 9:48
  • Using the official shutdown command should be as safe as any method of shutting down or rebooting the computer (with the the possible exception of shutdown -n. See man shutdown for a disclaimer about that particular flag. – TJ Luoma Sep 15 '18 at 16:27
1

You can take one of the 2 approaches one-by-one:

1) Command + Option + Escape brings up a window to force quit running apps.

2) In Terminal window, get the process_id by running ps -a and execute kill -9 <process_id> for the matching process.

If this doesn't work, quit all the other apps you can, make one last backup to time machine or equivalent and then kill all your user processes.

kill -9 -1

You can try the above several times by reopening terminal and as a last resort, pressing and holding the power button will force the system to a harder shutdown by pulling all power.

  • None of those two work - those are the things I have tried already :( Looks like I will just have to do something really battery-intensive – Ethan Wrightson Sep 9 '18 at 11:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .