I often move between Ireland, Germany/Switzerland (same timezone) and Israel.

I use MobileMe, iCal and (two) iPhones.

The problem is that Apple's calendar applications seem to assume that everything I do involves conference calls which happen at the same time in physical reality and hence in different times in each time zone.

I have lunch at 1 PM, regardless of whether I am in Ireland or Israel. I do not want to remember what time it is in Ireland when it is 1 PM in Israel when I make a note, in Dublin, for my lunch appointment in Tel Aviv.

I tried several settings (time zone support off, time zone support on) but nothing really works.

If I switch time zone support off (on ALL my devices), my lunch dates fluctuate a lot and I miss appointments because 3 PM is not 3 PM any more.

If I switch time zone support off (and miss one device), my appointments are subject to weird changes produced by the one device should I accidentally use it.

I finally concluded that it is best to leave time zone support on and tell all devices and computers that they are in Ireland. That way my lunch dates don't change any more.

But now all iCal and iPhone alerts are off and, here in Switzerland, alert me an hour late and for the wrong time.

How can I configure iCal and the iPhones to IGNORE time zones. I really have more local appointments than conference calls and iCal's behaviour is only good for conference calls.

  • 2
    I like this question, looking forward to some replies. I use timezone support as I travel monthly between the east and west coasts of the US, seems to work for me but my situation is less fluid than yours.
    – Richard
    Dec 13, 2011 at 12:11
  • I'm not sure what Apple's designers were thinking. Why on earth does a calendar need time zone support? Except for teleconferences and the odd television show, ALL my appointments are ALWAYS LOCAL. Hence if a noon appointment remains at noon forever, regardless where I travel, it will be the correct time. Dec 13, 2011 at 14:01
  • Note this question: apple.stackexchange.com/questions/12488/… Back then iCal's appreciation of daylight saving time moved all my regular appointments one hour forward. Sort of defeats the purpose of daylight saving time. Dec 13, 2011 at 14:03
  • Just flew to Ireland from Zurich. All my calendars are now configured without time zone support. But they still react to time zone changes. Only option I had was to set the clock one hour back manually without changing the time zone. Otherwise all my calendars get screwed up. This never happened with a paper calendar! Jan 28, 2012 at 0:16

5 Answers 5


I now include the actual time in the title of the event. For example: "9am Flight LAX -JFK" This way, if the phone changes my time setting (which it inevitably does regardless of how I have it set) I will still know what time my flight is. Doesn't work for alerts, but I often enter flight info in a different time zone from where I will take the flight and this helps to keep me from missing a flight.

  • My sentiments exactly. And including the time in the title is a good way to work around this bug. Ta! Aug 1, 2012 at 1:09

I think you might want to try the "floating" time zone; I believe this will let an event be at a specific hour, regardless of the time zone.

(As for why use time zones at all: We have an office in Zurich, Switzerland, and one in New York, US, and we share some of our calendars; having time zone support means, as an example, that I can see at a glance if somebody's at a meeting in New York (and thus I should maybe call them later).)

PS: Also see Changing the time zone for an event, but note iCal: Floating time zone Calendar events are not supported on iPod touch / iPhone or MobileMe Calendar; iCloud supports "floating" (just tested), not sure about the iPhone...

  • As you say, iPhone does not support "floating", hence this is not an option. I realise the benefit of time zone support for cases like yours, but I think most people have more local than remote appointments. I'd rather call someone who is in a meeting (and won't answer the phone) then deal with moved lunches. Dec 14, 2011 at 9:29

the only viable option i've found is to: 1) if you use iCloud, do not sync your mac and your i-device to the same calendar. i know this sounds stupid, but if you sync your mac and i-device to the same calendar, it is bound to mess things up. 2) turn timezone support on on your mac and choose the "floating" timezone when entering an event. 3) on your i-device, turn on timezone support, and select appropriate timezone for each entry (pain in the ass)!

similar issue exists with the mail program both on mac and iOS. if you email me from LA at 1am and say i am in NYC, your email will show as being sent at 4am. and if i reply to you immediately, the quoted text will say something like "on Jul 19 at 4:00am, you wrote". well, it is only 1am in your town, so how could you have written me at 4am? and if go back and forth, pretty soon we won't' be able to tell who say what at what time. the problem is even more pronounce across international border. i've sent feedback to apple about this many times, but they seem to think their way is smarter.

  • Generally a good idea except for the part of not syncing the devices and the Macs with the same calendar. It defeats the purpose. I wonder what made people think appointments have time zones. Jul 19, 2012 at 15:00
  • well, i just played around with my iPhone and mbp a bit, and i found a possible solution. here is the setup:
    – Jim
    Jul 19, 2012 at 15:25
  • Where is the setup? Dec 1, 2013 at 10:34

The only thing that works for me without complication is to put the local time in the event title -- everything else is too confusing. It seems that apple could make this simpler.

  • You know, I honestly never considered that! Apr 20, 2013 at 21:49

well, i just played with my iPhone and mbp a bit, and here is a possible solution. here is the setup: suppose you are in NYC. enable both timezone support on your mac and iPhone. on the iPhone, go to settings, mail calendar > timezone support and select new york. enter all events with the appropriate timezone (PAIN), and sync with iCloud, don't worry. now when you travel to other city like LA, you must remember to go to settings > mail calendar > timezone support and manually change the timezone to LA, as there is no automatic way to do this. now everything will show up at the right time. i know this probably won't work for me because i'll always forget to change the timezone when i travel to other cities, so my schedule will show me the wrong time. now i don't know if you set the alarm, whether it will go off even you don't manually change the time zone.

  • That's pretty much what I did except with Zurich and Dublin and that's when the problems started. I now leave everything in one time zone and this appears to work for the moment. My 12:00 lunch remains at 12:00, even when I eat in another city. Jul 19, 2012 at 19:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .