Title is self-explenatory. I really didn't do anything special, all epubs, PDFs etc are gone. I restarted the computer, same result. I have only used it from my MacBook, no iPhone, iPad or anything else.

I checked time machine at username>library>contents>com.apple.BKAgentService>data>documents>ibooks>books and weirdly I could only find books starting from many months ago and not sooner. For at least the last 3-4 backups this folder was empty, which is insane as I use iBooks every day and that definitely wasn't the case until now.

I restored these books, copy and pasted them at the present time username>library>contents>com.apple.BKAgentService>data>documents>ibooks>books folder but to no avail.

This is so weird as we're talking about hundreds of books!

Is there a standard dumb thing I may have unknowingly done for this to occur? What else can I try to resolve this?


My first instinct would be to try logging out of the iBooks Store and then logging back in. You can do this as follows:

  1. Launch iBooks
  2. Go to Store > Sign Out
  3. Wait about 30 seconds and then go to Store > Sign In...
  4. Enter your Apple ID and Password
  5. Click on Sign In
  6. Click on Get Started
  7. iBooks should now populate with all your books, PDFs etc.
| improve this answer | |
  • tried it but nothing. its so so so weird. in the end i restored a folder from the timemachine and opened all the epubs all at once, so they automatically returned to their place in ibooks. they even filed themselves at the collections i had set up. thanks for you input tho dude. – ineedhelplol Sep 9 '18 at 11:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .