Apple Mac Pro (early 2009) 4,1 -> 5,1 Firmware upgraded macOS 10.14 Mojave Beta 10 Tweetbot 3.1

Hello, I upgraded my machine to Mojave Beta 10 yesterday via a somewhat devious route http://dosdude1.com/mojave/. I don't know if this devious route is the cause of the problem, but I am having problems starting a couple of apps, notably Tweetbot 3.1. When I attempt to open the app, I get the message...

enter image description here

I've tried doing as the message suggests and deleting the app and downloading again from the App Store, and I've also tried @tweetbots suggestion of rebooting after deleting and before downloading. I get the same error message each time.

  • google search of these symptoms cropped up a lot in 2015 following Apple's failure to renew an out-of-date security certificate relating to the App Store.
  • a tweet from the app's authors @tapbots advising someone to do the above process but ensuring that they are logged into iTunes before they download. I tried this, but again I got the same result.

Can I run a command to test the integrity of apps without waiting for Apple support or vendor support to know if I can fix this myself?

UPDATE: I ran the codesign on one of the offending apps, Tweetbot, and got the following message...

Executable=/Applications/Tweetbot.app/Contents/MacOS/Tweetbot Identifier=com.tapbots.Tweetbot3Mac Format=app bundle with Mach-O thin (x86_64) CodeDirectory v=20200 size=28056 flags=0x200(kill) hashes=869+5 location=embedded VersionPlatform=1 VersionMin=658432 VersionSDK=658688 Hash type=sha256 size=32 CandidateCDHash sha256=7eb53c5bd255631bc46f3bee6965fed6de8b6049 Hash choices=sha256 Page size=4096 CDHash=7eb53c5bd255631bc46f3bee6965fed6de8b6049 Signature size=4555 Authority=Apple Mac OS Application Signing Authority=Apple Worldwide Developer Relations Certification Authority Authority=Apple Root CA Info.plist entries=35 TeamIdentifier=9JTH7AWHE6 Sealed Resources version=2 rules=13 files=31 Internal requirements count=1 size=224

I'm not sure what to do with this information.

Any ideas, anyone?

  • You can run Mojave beta on a firmware upgraded 4/5,1 [though 2 betas behind the dev version unless you are a paid dev] through the regular beta program. Then you get full recourse to the bug reporting tools too. – Tetsujin Sep 8 at 13:13
  • I've found a decent alternative in NightOwl. It works very well and is free! – carlcaulkett Sep 8 at 13:45
  • This is a great question and this error will happens more and more as certificate chains, code signing and app notarization become more mainstream. Knowing how to trace why the system asks for an app to be reinstalled or reports it as damaged will help those of us that don’t run stock systems or have a proper and clean os to test that app in isolation. – bmike Sep 8 at 19:40

Does it run with gatekeeper disabled? If so it can be a codesigning issue. There is a terminal command 'codesign': You'd want to look at the hashes and and certs auths in the output.

codesign -d --verbose=4 /Path/Application.app

Documentation regarding codesigning is here

  • Thanks for the reply @Hefewe1zen. Please see the updated original question. – carlcaulkett Sep 9 at 14:29
  • I enabled Gatekeeper and when I tried to run Tweetbot I saw in the Dock that it was repeatedly trying to start, but eventually it gave up and produced the "App is damaged" message. – carlcaulkett Sep 9 at 14:38
  • Interestingly when I enable Gatekeeper in System Preferences, and then go back into System Preferences again I find that the Gatekeeper has reverted to a disabled state. A Mojave bug perhaps? – carlcaulkett Sep 9 at 14:42

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.