3

I have a Mac Pro model 1,1 which used to work with Ethernet pluged into either RJ45 socket. It now does not recognize either connection.

Since this could be physical or sortware, how can I further diagnose the problem?

  • Are you sure the cable works correctly? The machine has been powered completely off and on again? – Thorbjørn Ravn Andersen Sep 8 '18 at 8:42
  • Thanks, Yes even got a new cable but old one works ok on my MacBook pro. Multiple power down and reboots. – Martin Coull Sep 8 '18 at 8:45
  • Locate the original installation media and figure out how to run the hardware diagnostic tests. – Thorbjørn Ravn Andersen Sep 8 '18 at 8:51
  • Do not have original discs, Second hand 4 month ago. It worked then, An auto matic upgrade has been done since then. Currently working off a USB to Ethernet adaptor which is slower than it used to be. – Martin Coull Sep 8 '18 at 8:57
  • Have you tried a different port on the switch? – Allan Sep 8 '18 at 9:14
1

Since you don't have the original disks (and therefore don't have Apple Hardware Test), I would try downloading AHT and running it from a USB. The steps to do this are as follows:

  1. Create a bootable USB flash drive by using Disk Utility's Erase function. Make sure you choose OS X Extended for the format and the GUID Partition Map for the scheme. For the purposes of these steps, also give your USB the name AHT when you're erasing it.
  2. Download the AHT for your particular Mac Pro 1,1 here
  3. Mount the downloaded image (it should mount as AppleHardwareTest)
  4. Now you will need to copy the AHT to your USB flash drive. To start, Launch the Terminal app (usually found within the Utilities folder)
  5. In the Terminal window, enter the following:

    cp -r /Volumes/AppleHardwareTest/System /Volumes/AHT/

  6. Now we need to make the USB flash drive bootable, so enter the following line in Terminal:

    sudo bless --folder /Volumes/AHT/ --file /Volumes/AHT/System/Library/CoreServices/.diagnostics/diags.efi --label AHT

  7. Enter your Admin password

  8. Leave the USB flash drive plugged in and restart the Mac Pro

  9. Immediately hold down the Option key

  10. Select the AHT from the list and boot up

NOTE for other readers: - Both the Terminal commands and the download link used here were written for this specific question. Please do not follow these steps unless you're also wanting to download and use AHT for the Mac Pro 1,1 (i.e. these instructions will not work for other Mac Pro models).

  • Thank you for that will get a new USB to do that and let you know how I go. Martin Coull Bairnsdale, Victoria, Australia – Martin Coull Sep 8 '18 at 10:22
  • OK, problem was a small chip that hold the setup data for the Ethernet ports - that is a 8 pin surface mount chip 32MB rom which was custom programmed by apple. I would have to get a new (well second hand ) motherboard to fix the problem. Just keeping my eyes out for cheap Mac Pro int the local area. – Martin Coull Sep 13 '18 at 11:09
  • Ah, okay. At least you sorted out what the problem is. Do you know whether the chip is required if you use a 3rd party PCI ethernet card? – Monomeeth Sep 13 '18 at 11:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .