0

I have IntelliJ IDEA and a MacBook Pro with an Italian keyboard.

I want only be able to use keyboard shortcuts.

I see for example that I should be able to comment a block of lines with:

alt + cmd + /

But when I try nothing happens. Absolutely nothing.

I think the Italian keyboard should be the key of the problem.

Any idea?

1

Maybe this shortcut is not assigned in IntelliJ (at least not for the italian keymap) or a different shortcut is mapped to block comments.

First you can lookup if this shortcut is mapped (Preferences -> Keymap (or search for keymap). The keymap preferences dialog contains a search field (top right). If you search for 'block', you will get all mappings.

You may assign your desired shortcuts (double click on "Comment with Block Comment") and IntelliJ even warns you if your shortcut is already assigned.

Additionally there is an open issue in their issue tracker for "screwed up shortcuts" for many non-US keyboard layouts (see https://youtrack.jetbrains.com/issue/IDEA-167193)

  • Hi, I’ve double checked. The shortcut is mapped. Another useful shortcut I’ve tried without success is cmd + alt + o (optimize import) – freedev Sep 7 '18 at 11:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .