0

I have a Mac with High Sierra (10.13.6) and I am unable to disable the spell checker.

I've tried going to System Preferences -> Keyboard -> Text and unchecking all the boxes but the spell checker still works. Every time I type "echo singlequote" (singlequote was meant to be enclosed in diamonds) the system tries to guess what I'll type next.

I have also disabled System Integrity and renamed the /System/Library/Services/AppleSpell.service/Contents/Resources directory, but the system still tries to guess my typing every time I use quotes.

I don't have the issue on another machine with High Sierra.

I can't type without checking the screen every time I type a single or double quote, or even the ^ symbol. Having to hit the space bar every time I type a quote is driving me mad.

Does anyone know how to stop this spell checker from jumping in every time a type a quote?

5
  • The whatever checker works system-wide. I've turned off all the auto-check-doit-myself-correct options i could find in iTerm, Terminal, textedit, Chrome, Safari.
    – wotmof
    Sep 7, 2018 at 13:02
  • I'm trying to figure out what the actual issue is from your long rant of a question. Please try and edit out the unnecessary bits and concisely describe exactly what is going wrong. What specific sequence of typing triggers the problem and what do you see on screen?
    – nekomatic
    Sep 7, 2018 at 13:21
  • Independently of the application i'm using, the spell whatever checker works (and eventually replaces single/double quotes. Example: singlequote followed by c, is replaced with ç) even if i have turned all the typing check/corrections off. I thought i made myself clear already, sorry.
    – wotmof
    Sep 7, 2018 at 16:57
  • Post this as a separate question: "The keyboards on these new MacBooks are great, but the arrow buttons on the bottom right have been changed and now are useless. I've been trying to post on Apple forums but the page asks for Apple ID and dies using different browsers. What is happening?"
    – airsquared
    Sep 7, 2018 at 17:37
  • @wotmof, Please have a look at: What should I do when someone answers my question? Sep 7, 2018 at 21:50

1 Answer 1

1

Go to System Preferences > Keyboard > Input Sources and make sure you have only one item on the list, and that its name is US or ABC (and not US International PC).

(Note that your problem is not connected to spellcheck. You are using a special keyboard designed to use various symbols to create the accented characters needed for Spanish, French, German, Italian, etc.)

1
  • Oh my god! I had "U.S. International PC" selected. I have added "U.S", and removed the other one. Now the whatever checker is gone silent! Thanks a lot, no more headaches! Thanks, again:)
    – wotmof
    Sep 7, 2018 at 17:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .