1

I had ffmpeg 3.3.4 working very well on my system, then I force uninstalled all versions of ffmpeg including the version above while meddling with a dependency for another application.

Now, I cannot brew install ffmpeg because it is a 4.0.2 version which gives an error about using macOS 10.9

How can I get back ffmpeg on Mavericks?

This is what I am trying right now:

curl https://www.ffmpeg.org/releases/ffmpeg-3.4.4.tar.xz | tar xz
cd ffmpeg-3.4.4
./configure --prefix=/usr/local/Cellar/ffmpeg/3.4.4 --enable-shared --enable-pthreads --enable
make
sudo make install
brew link ffmpeg

The problem is configure command is not working, what should be the correct configure command. Any guidance for getting back ffmpeg on Mavericks?

1

This one worked for me.

./configure --prefix=/usr/local/Cellar/ffmpeg/3.4.4 --enable-shared --enable-pthreads --disable-x86asm

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .