2

I need help. I have a MacBook Air.

I have a new battery. It has only 21 cycles in it. Out of nowhere it stopped charging. I checked my battery status and it showed as NOT CHARGING. (More specifically "Charging: NO"). So basically I have to use it plugged in. I've tried the SMC restart and many other options I've found here and other places online.

Does anyone have a solution or an idea on what I could do? Thanks!

Oh, I've tried with 2 different chargers as well.

UPDATE: I just finished talking with MAC assistance and they also made me press another combination of keyboards: POWER + SHIFT + COMMAND + P + I + R (or something like that) and the system rebooted. But that didn't help either.

Here's a screenshot:

  • sometimes you have to "snap" the plug few times, like pull it out a bit and let it snap in again, our tilt it up or down and let it snap back in. – Ruskes Sep 2 '18 at 21:32
  • The plug does contact with the MAc. It turns green and everything. The mac shows as 100% charged on the desktop, but if I go to the battery information it shows like not charged and not charging. – Laya Marconi Sep 2 '18 at 22:30
  • Thank you for clarifying. Could you tell us what does it show for battery charge in mAmp ....Charge Remaining (mAh) – Ruskes Sep 2 '18 at 22:46
  • 1
    Charge remaining: 6696 – Laya Marconi Sep 2 '18 at 23:06
  • 1
    Here's a screenshot: photos.app.goo.gl/dNzDo9onrZTpuJpy9 – Laya Marconi Sep 2 '18 at 23:14
1

Apple is pretty clear that if one SMC reset doesn’t fix your power issue, the next step would be a hardware repair.

Now before you do that, consider the machine stops charging the battery past 90% or so and you are above 97% charge. No panic and just let the battery drain down a bit and make sure it’s just not resting the charge.

  • (6885 - 6696) / 6885 = 0.027 which means you're not discharged enough to resume adding charge to the battery according to the system information. Your battery health is good.

annotation from system information showing a normal situation for charge not being applied

Assuming it doesn’t start charging when you’re at 85 % capacity, then seek a repair. For now, make sure your backup is running just in case, but nothing is amiss in regular readings whatsoever.


That repair would be to take a new adapter to your Mac to be sure it’s not the adapter or a stuck pin, then they would inspect and replace the MagSafe port or the battery or cables or the Logic board (or even a combination of some or all of the above).

You did good work making sure it’s not something simple so unless you missed a stuck pin in your adapter or physical debris in the MagSafe port, time for a repair.

There are probably dozens of other similar or duplicate questions here if you search on the right or use the main search.

0

Upon closer evaluation of your Battery report,

it shows Amperage to be positive (like charging). Amperage +81mA

Normally when run on battery without charger, the Amperage is some negative number like -400 mA, meaning (showing) the amount of current that is been consumed.

Something does not add up here. I shows it is charging but does not report it correctly.

As comparison here is what I have and no charger plugged in. As yo can see it shows negative (-626 mA) which is correct value.

enter image description here

This is your battery report. Is the battery Apple original ?

enter image description here

In summary and further advice...

Your charger is working and it is charging the battery.

However the circuit mounted on the battery is not working.

To verify, make note of the "Charge remaining" while plugged in and check again in a hour to see if it is going up or down.

  • I don’t get the part where you say “something does not add up here” as everything OP posts adds up perfectly. The charger is working, the battery is idle, no large charge current is flowing since the remaining mAh is so close to FCC. – bmike Sep 3 '18 at 8:09
  • 1
    Nice edit - thanks for clarifying what didn't add up. – bmike Sep 3 '18 at 17:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .