1

I have been using an Apple Magic Mouse "1" for quite some time now on my Windows 10 PC and I was very content except the damn batteries that needed replacing every once in a while. So I bought an Apple Magic Mouse 2. Shouldn't be that difficult, right? Disconnect the "1", connect the "2" and go!

Nope. The mouse works fine except it doesn't scroll.

  • I've (re)installed the latest AppleWirelessMouse64.exe from the Bootcamp support software (tried both 5.1.5722 and 5.1.569) and also the BlueTooth driver.
  • I've tried switching the mouse off and on again (disconnecting, reconnecting), rebooting, unpairing and (re)pairing
  • I've tried MagicUtilities; at first it installed but then my mouse became near unusable. The pointer would jump instead of move with second+ intervals, the mousebutton(s) didn't react to anything. Even not after rebooting, again trying all of the above with pairing, unpairing, switching off and on etc. On boot the mouse worked fine; I could click and move it without issue until MagicUtilities loaded (in the taskbar). Then it seemed to break. So I then uninstalled the software. However the mouse still kept "jumping". It turns out MagicUtilities also installs a driver but doesn't uninstall it didn't remove it in my situation. Uninstalled the driver manually, which failed for some reason on several occasions, but, a couple of reboots and "persuading" later I had my mouse (or mice) finally back to where I got started.

But, still, the MM1 scrolls just fine, the MM2 doesn't want to. Here's some more of my findings:

  • Both mice connected doesn't seem to cause any trouble but, for every step above, I also tried with only the MM1 or MM2 connected.

  • When only the MM1 is connected and I open the Mouse settings it has a "scroll-wheel" tab. When the MM2 is the only mouse connected the tab disappears. When both are connected the tab shows.

  • When I go to the hardware tab there's a difference between both mice's "location". One, the MM1, shows "On Apple Wireless Mouse", the other, MM2, shows "On Bluetooth HID-device".

Since I've exhausted all of my ideas (I also tried looking at the registry to find differences etc. (didn't change anything ofcourse)) I tried to go back to giving MagicUtilities another, rather reluctantantly, shot; however: it won't install anymore: "The required Magic Mouse Driver installation failed. Error code is -2147418112". Again, I've tried rebooting etc. but that doesn't help anything.

Oh, I have even tried:

  • Connecting the MM2 to my MacBook air. Scrolling works fine. Ofcourse.
  • Since my MM1 has a name like "<joe's mouse>" I even tried renaming the MM2 to "<joe's mouse>" on the MacBook and then going back to my PC, connecting the MM2 (solely) and hoping it would pick up the MM1's settings. To no avail, as expected. But there's always that little spark of hope...
  • Disabling Bluetooth Battery Monitor, thinking it may interfere somehow. Didn't make any difference. It does, however, report two mice and two battery levels which is nice.

So now I'm sitting here, at my desk, with a MM1 and MM2, simultaneously (and consecutively) connected and working all fine and dandy EXCEPT for the frikkin' scroll on the MM2 whereas my MM1 scrolls just fine. Thats €89 down the drain...

So... now what? Anybody with the tip to get my beloved MM2 to work on my Win 10 64bit machine?

1

Here is Magic Utilities.

At this point in time, we are not sure what went wrong in your specific case, but our drivers do uninstall when uninstalling the Magic Utilities.

You can always uninstall any Windows driver with Windows pnputil from the command line. First enumerate all drivers, to find the relevant eomXX.inf, then do a forced uninstall of that oemXX.inf file.

Note: The BootCamp drivers from Apples official webpage do not support the Magic Mouse 2.

We'll contact you via email to help you to solve your specific problem.

The Magic Team

  • Hi and thanks (and awesome!) of you to reply here! I have answered your email but, as I suggested in my reply, maybe we can keep it on here so other people also can read along and maybe find solutions to their problems as well. I have rectified my question about the driver not being removed; I guess that would be something specific to my system that happened to fail or something. Sheer bad luck... I'll look into using pnputil (never used it before) and try to figure out how to clean my system of the Apple drivers (and yours) and try to get MagicUtilities (re)installed again for another shot. – RobIII Aug 31 '18 at 23:44
  • Also, maybe offtopic, I'm using sharpkeys with this config (disclaimer: I wrote the Wiki article but am otherwise unrelated). I'd like to keep using it since your MagicUtilities doesn't allow me to freely configure some keys (or I don't see it in the screenshots at least for F16-F19 for example). So all I installed was the Magic Mouse component, not all three (Mouse, Keyboard, Trackpad). Just FYI. It might matter (but I doubt it). – RobIII Aug 31 '18 at 23:50
0

After a LOT of trial-and-error I have these findings:

I had to completely uninstall Bluetooth Battery Monitor; this was the main culprit. Simply "exiting" wasn't enough, only when disabled on startup I was able to make some progress and only after actually uninstalling everything started working as it should. Somehow these two applications seem to interfere / bite eachother.

I had issues with the mouse "jumping", not registering any clicks (it did, until Magic Utilities was loaded), I had it showing up as "not connected" in Magic Utilities and I had it actually show up as connected whenever I unpaired and re-paired but then in less than 10 seconds it would go back to "not connected" etc. It caused all sorts of strange problems. Clicking / moving the mouse at times caused beeps to come out of my speaker (like in the good old days when the keyboard buffer was full or when an application hung in Win 9x).

Uninstalling BlueTooth battery monitor fixed all my problems. Which kind of sucks since I liked it...

0

If your goal is simply to get the mouse up and running then Apple's drivers will work just fine on a mac or a pc running windows 10 for free. You just can't download them from the apple website directly.

  1. Download Brigadier https://github.com/timsutton/brigadier/releases
  2. Open up the command line, navigate to the folder with brigadier
  3. Run "brigadier.exe" if you are on a mac or "brigadier.exe -m iMac19,2" without quotes on a pc (-m specifies the model's drivers to get. anything recent should have the proper mouse drivers) This will leave a new folder something like bootcamp-###-##### in the directory from where you ran brigadier
  4. open Windows Device Manager
  5. Under Human Interface Devices right click on the Bluetooth HID device and click update driver
  6. Click Browse my computer for driver software, then let me pick, then have disk
  7. navigate to the bootcamp folder downloaded with brigadier go to BootCamp\Drivers\Apple\AppleWirelessMouse within this folder and select the AppleWirelessMouse.inf file.
  8. Click next. The mouse will not work. This is expected. Just reboot the computer and scrolling will work!

This is a free solution that uses apple's drivers. It seems like for such an expensive piece of hardware they would make the driver easier to install on windows too. I guess that's not the Apple way though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .