1

I am running a Apache2 on my MBP on macOS 10.13.6. I setup everything well, and it works when going to localhost/~user. In my ~/Sites folder, I have a symbolic link to a folder on my Desktop with my website files in it. I can navigate to the website with localhost/~user/mysite only sometimes. If I get a 403 error, it is fixed with running chmod a+x ~/Desktop. This fixes it until about the next reload, but almost every time I make a change and try to reload the site, I have to run the chmod command. I use Brackets for my web editing, and I have iCloud Drive syncing enabled for the Desktop folder. I think that it is either the iCloud Drive resetting permissions for the folder or Brackets doing something weird. Has anyone had a similar problem and fixed it? This is really annoying and it's slowing down my development.

EDIT: My httpd.conf file: pastebin

EDIT: It seems my question was unclear, but what I was asking is why the permissions keep changing on my ~/Dekstop folder. I do chmod a+x ~/Desktop and it fixes my apache 403 errors, but after about a minute this changes and I have to run the chmod command again. I was thinking it might be iCloud Drive sync changing something, or Brackets messing up permissions.

  • A symlink on your desktop isn't going to change the permissions for a folder somewhere else. What does your httpd.conf file look like? (Most likely off topic since it will be related to Apache and not Apple, but let's take a look). – Allan Aug 31 '18 at 17:17
  • @Allan I added a pastebin to the post. (pastebin.com/vJaCEqdR) – Minebomber Sep 1 '18 at 18:18
  • @Minebomber I am confused on what the question is here exactly? Can you edit to clarify what you exactly are asking? Do you want to know about permissions or how to get apache to work with desktop folder? – JBis Sep 1 '18 at 18:20
  • What does ls -ld ~/Desktop show when it is broken – Mark Sep 1 '18 at 18:27
  • did you create your symlink from the document root to the desktop: ln -s /Users/mark/Sites /Users/mark/Desktop/Sites – Allan Sep 1 '18 at 19:17

You must log in to answer this question.

Browse other questions tagged .