Today my computer started getting really slow and freezing alot, so i rebooted. HOwever it won't boot up again, keeps getting stuck on the grey screen.

Here's what i've tried:

  • Startup in safe mode - fails with the following error:

    ** The volume Macintosh HD could not be verified completely.

    /dev/rdisk0s2 (hfs) EXITED WITH SIGNAL 8


    disk0s2: I/O error.

    Invalid node structure (4,1211)


    fsck failed!

    Kext loading now disabled.

    Kext unloading now disabled

    Kext autounloading now disabled.

    Kernel requests now disabled.

    Can't get kextd port.

    syncing disks... Killing all processes


And it just gets stuck there.

  • Boot from external hard drive - gets stuck on firewire symbol bouncing around the grey screen.. can't even get to screen where i choose which drive to boot from

  • Boot from OS X CD - fails - grey screen same as normal boot

  • Reset PVRAM - seems to work but no change

  • Reset Open Firmware - fails - grey screen same as normal boot - can't get to terminal window or anything

  • Single User Mode /sbin/fsck -fy - fails - same error as safe mode verbose above

I'm really stuck on this. My computer is out of warranty so Applecare not really an option. I'm currently on holiday in Borneo so Apple store/ Genius Bar not an option either atm... earliest i could get to a Mac store would be after xmas when i'll be in the UK. I'd rather not wait that long.

Any other suggestions?

The fact that i can't boot from CD or USB drive is kind of weird.. usually i can use my cloned drive to boot from and verify internal disk etc.. not this time.

Hoping somebody can help i'm really screwed if i can't get it sorted now... freelance clients to support etc etc. :(

Thanks heaps greg

  • Just to confirm, even if you hold the Alt key right after hitting the power button (and before chime) you don't get a boot selection menu?
    – macaco
    Commented Dec 12, 2011 at 17:41
  • Wow macaco.... you know i never knew about that alt key option on startup, after all the articles and reading i did which included all of the shortcuts for booting, that one wasn't there. And that's the one that got me in.. i was able to boot from my clone drive, and running repairs on the disk now... seems its corrupted and going to need a reformat. damn. Hooray for backups :) Thanks macaco you're a legend
    – Jeeby
    Commented Dec 13, 2011 at 4:06
  • Turns out I had a dodgy harddrive. This same thing happened 3 times (i think) before an apple store finally correctly diagnosed the issue. New harddrive, never had the problem again. Go figure!
    – Jeeby
    Commented Mar 4, 2014 at 2:45

2 Answers 2


(Just to provide an actual answer that you can accept).

It looks like so far you've not actually tried accessing the Boot selection menu. Rather, you've mistakenly entered target disk mode.

Press and hold the alt key immediately after powering on the system (before you hear the chime). You should get a selection of the available boot volumes (if any). If you have an external drive or install DVD, this should appear. Use the arrow keys to navigate to your choice and hit enter to boot from that volume.

Use your alternative boot to backup data and repair/reinstall your main boot disk.

  • Thanks macaco that's exactly what i did wrong. I have now booted to my cloned external drive, backed up from my internal drive, formatted and cloned back over.. all good now. Any ideas how i can avoid such corruption in the future? Regular disk verification and repairing? Oh, the reason i couldn't boot from CD is my OS X DVD is dodgy.. i burned a copy of mine when i left home so i didnt have to take the original, but unfortunately i must have stuffed it up. Damn. Guess i'll have to buy another one somewhere along the way.
    – Jeeby
    Commented Dec 14, 2011 at 4:32

Had this almost exact same problem, but going from lion to mavericks. I pressed alt, used the restore drive and re-did everything! Thanks a bunch you all. It is currently restoring Macintosh HD from our time machine! I'll keep you updated. It's at 0.5%... 0.6%...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .