1

My laptop running 10.13.6, has been working great without any issues until I restarted it on Monday. After I logged in, it got stuck on the loading screen and displaying a loading icon for over an hour.

Over the past couple of days, the only way I can get past logging in, is from restoring from a time machine backup. I have tried the following without any luck:

  1. Boot in Safe Mode - this freezes like this every time enter image description here

  2. Repair the Disk

  3. Reset NVRAM and PRAM

  4. Reinstalling the OS

I have seen that running diagnostics on restart might let me know what is going on if it is a hardware issue, I am just afraid to restart my computer because it takes all day to restore. Can this be run from terminal without restarting? Is there anything else I should be trying before I go into the Apple store?

  • try to find out where it gets stuck, by booting in single user mode "Command S" it should display lines of text, note what it shows when it hangs up – Ruskes Aug 30 '18 at 1:49
1

On a hunch

repair your disk

Boot in Single user Mode "CMD S"

As the Mac boots in this mode, the screen reports each step of the process. Wait until the scrolling white text stops. The last line should end in root#.

Right after the root# prompt, enter the following:

/sbin/fsck -fy

Press the Return key.

You’ll see the prompts in the picture above as each part of the hard drive’s directory is checked. (Checking extents overflow file, Checking catalog file, Checking multi-linked files, etc.) It will take a few minutes. At the end, if your drive was OK, the screen will say “The volume (name of your hard drive) appears to be OK”. If any repair was made, you’ll see the prompt, “FILE SYSTEM WAS MODIFIED”. Then, you’ll see the root# prompt again.

Right after the root# prompt, enter the following:

reboot

Press the Return key. Your Mac should restart normally.

  • I tried this as well with the same outcome. I had to restore from a backup. – tonjaggart Aug 31 '18 at 17:55
  • well we tried, but tell us what was the message you got, was your disk bad or not ? – Ruskes Aug 31 '18 at 17:57
  • I ran it again and it said everything is ok, but I am still having the issue. Here is a screenshot: link – tonjaggart Sep 18 '18 at 5:36
  • sorry, we tried to repair your disk and it did not work. – Ruskes Sep 18 '18 at 5:46
  • did you run the Apple hardware test ? support.apple.com/en-us/HT201257 have you added any new apps recently ? – Ruskes Sep 18 '18 at 5:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .