1

I recently started using 1Password on my MacBook Pro running macOS High Sierra 10.13.6 with Safari Version 11.1.2 (13605.3.8).

I have both the macOS app from the Mac App Store and the Safari extension for the app installed from 1Password - Safari Extension Gallery.

I have been looking forward to give 1Password a try for a very long while (which I finally did). I am quite satisfied with the feature set and simplicity of the product.

However, I updated to the latest macOS client released on the Mac App Store today, which broke the Safari Extension for me. The screenshot below shows the release notes.

enter image description here

Now, when clicking on the Safari extension button on the toolbar, with a website open (which is already added in the 1Password database), does the following instead of offering to fill the password:

  1. Nothing happens for a few seconds.

  2. Following alert is shown by Safari.

enter image description here

  1. Irrespective of whether I click Allow or ignore the alert and wait, this error is shown.

enter image description here

The 1Password macOS app doesn't launch. Even clicking on Try Again does nothing.

The thing is, that, this setup was working flawlessly until I updated the macOS client.

What could have possibly gone wrong? I have not attempted any major salvage operations, as this is the first time I have setup 1Password app on my Mac.

I am thinking about doing a fresh install of the app and checking if the issue persists (thereby concluding that this is a bug in the app release).

I have already clicked on the support site link mentioned with the error message, and have reinstalled the extension, following by restarting the browser followed by restarting the Mac, but to no avail.

enter image description here

I have not taken any other steps on my own and though of seeking advice from experienced 1Password users. (I have been using the app for a couple days. I am currently under 1-month free trial with a high level of satisfaction and intend to convert to paid plan at the end of trial period expiry.)

Salvage Update: It is observed that that the mini app which is resident in the Menu Bar is no longer recognizing the browser extension and asking to install it. Clicking on the install browser extension button directs to the Agilebits Safari Extension Galley web-page which acknowledges the extension installation. Removing and re-installing the extension has no effect.

  • Have you tried deleting the safari extension from the 1Password site and using the extension from the Apple extension page? I had a similar problem many months ago and doing that fixed it for me (what caused my issue might not be related to your issue, though). – fsb Aug 29 '18 at 22:33
  • I installed the extension from the Apple extension gallery page. – Nimesh Neema Aug 29 '18 at 22:35
1

This issue is all over the Agilebits Support Forum today.

Agilebits released 1Password for Mac v7.1.1 to address this issue. Go back to the Mac App Store and download the update.

If it's not available on the App Store yet (review process delay), try downloading direct from 1Password's download page.

*Edit: Posted on their forum from 1Password support:

A build flag got set improperly / prematurely which caused WebSockets (which Safari relies on) to be turned off for the 7.1 build. We disabled that flag for 7.1.1. Safari is the only browser which currently uses WebSockets, the rest use Native Messaging. We are working toward moving away from WebSockets for Safari and toward Apple’s Safari App Extension framework.

  • I had a hunch that they mistakenly pushed a buggy release. No update shown in the Mac App Store despite refreshing. I'll keep trying and update (pun intended :D). – Nimesh Neema Aug 29 '18 at 22:40
  • Try the direct download, people are reporting it fixes the issue. When I get done with work, that's what I'll be doing :-). I've been a 1Password user for years and my entire family uses their family plan. – fsb Aug 29 '18 at 22:42
  • Great! Hoembrew appears to be picking up V7.1.1.1. I'll zap the Mac App Store version and install via Homebrew. Do I have your go ahead for this Sir? – Nimesh Neema Aug 29 '18 at 22:45
  • Launched 1Password main app, verified that the date is synced between desktop app and web-app, removed account from preferences, uninstalled the Mac App Store version of the app, installed the app via Homebrew Cask. Voila! sanity restore :D Would prefer Homebrew Cask over MAS for app installs in future to ensure quick access to updates. – Nimesh Neema Aug 29 '18 at 22:58
  • 1
    Glad it worked for you! – fsb Aug 29 '18 at 23:39
1

I've seen this one. It just means that the 1Password background app is either hung or quit somehow.

Usually a reboot does the trick, if not after a reboot launch the 1Password app, and see if that does it.

Still not working? Uninstall the extension and reinstall it. that should do it

  • Thanks for the answer. Already tried all these steps in the exact same order, but to no avail. Only thing remaining is a complete re-install. – Nimesh Neema Aug 29 '18 at 22:35
  • @NimeshNeema Maybe you’ll need to edit the question down a bit - if you know the mini app runs and the main app runs - then you are totally right, might be browser extension bug and need to run the troubleshooting / diagnostic steps in the app itself - it will report what’s not working. – bmike Aug 29 '18 at 22:39
  • @bmike I'll do that. I am still diagnosing and troubleshooting. I had a strong hunch that a buggy release somehow made it to the Mac App Store (which appears to be confirmed by @fsb). – Nimesh Neema Aug 29 '18 at 22:42
1

I’ve had great luck with the vendor support or asking them on Twitter to point me to the document that addresses my situation (or yours in this case), but the first thing I would try is to be sure the mini version is working in your menu bar. There are diagnostics and until the mini version is running - no extension can operate.

  • Once you’ve verified that the mini version of the app runs when the main app is closed
  • Next try a different browser to narrow down if this is Safari only or all browser extensions.
  • You can also reduce the error chances by running the main app and the mini app and then relaunching your browser.

You have a super detailed question and this answer is more about how to triage so please make a new answer once you get the proper solution. This can stand on how to triage and maybe not actually fix if this ends up being Safari version specific.

  • Mini version was disconnected from the extension. Asking me to install the browser extension. Failed to recognize the re-installed extension. I'll edit this into main question. – Nimesh Neema Aug 29 '18 at 22:47
  • Thanks for this comprehensive writeup. Clear to understand and helpful in debugging. – Nimesh Neema Aug 29 '18 at 23:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .