2

I have an occupational need for about seven different keyboards including US, Greek Polytonic, Classical Hebrew, Ethiopic, Semitic Transliteration, and extended Latin keyboards (college professor). But I have had a devil of a time with High Sierra. Custom Keyboards that I install (ones that worked just fine in earlier OSs) don't stay accessible in the input menu, and disappear from the input sources menu. I have tried various fixes, to no avail. NOW, I've tried to pare it back so that I have no custom keyboards installed at all, just the native US keyboard entry. But my input menu lists multiple duplicate copies of keyboards that the system preferences doesn't even acknowledge are installed! HELP. Apple has to fix this issue.

These are my current input sources dialog (System Preferences > Keyboard > Input Sources) and my current input menu drop-down (Menu Bar upper right).

enter image description hereenter image description here

  • 1
    Set up a new user account and see if you have the same problem when you ad layouts to that. – Tom Gewecke Aug 28 '18 at 15:48
  • 1
    Have you verified that the Keyboard Layouts folder in Library and Home/Library is actually empty? To get to Home/Library, you hold down the option key while doing Finder > Go. – Tom Gewecke Aug 28 '18 at 15:50
  • 1
    Have you checked Siri and gotten rid of antivirus as suggested in the answer to this similar question? apple.stackexchange.com/questions/305136/… – Tom Gewecke Aug 28 '18 at 15:51
  • 1
    Also post in the Ukelele group. I think your problem is uncommon and specific to your install rather than any bug in MacOS. It should be fixable. groups.google.com/forum/#!forum/ukelele-users – Tom Gewecke Aug 28 '18 at 15:55
  • Hi Tom Gewecke... did try that first suggested fix, but the problem recurred. The keyboard layouts folder was NOT empty, and when I emptied it, the duplicate but unselectable keyboard names disappeared. HOWEVER, the problem simply recurred when I attempted reinstallation. Yes, Siri is deactivated and I don't use antivirus. Also.. I did post in the Ukelele group and so far those users have been helpful, but my problem isn't solved yet. – Matt Baldwin Aug 30 '18 at 13:57

You must log in to answer this question.

Browse other questions tagged .