I installed the Charles web proxy, now if I start VPN and without starting Charles, I cannot browse the web. The web browser says proxy error. But i unchecked all the proxy in web connections.

I wonder what Charles has done to my computer. Right now, I have to run Charles simultaneously with VPN, which is annoying. Anyway to solve it? Thanks.

  • Fixed. Need to turn off the proxy settings in VPN connections as well.
    – Frankel
    Dec 12, 2011 at 4:34
  • Can you please post this as an answer (maybe even listing all the things/steps you did to undo the installation) and accept it (may have to wait a few days for that). This way, future visitors may benefit at well.
    – nohillside
    Dec 12, 2011 at 18:08
  • Sure, I will do it.
    – Frankel
    Dec 14, 2011 at 1:31

1 Answer 1



Charles use itself as a web proxy to sniff on every request passing through the network interface. Besides turn off Charles in its proxy settings, you still need to check if the web proxy is turned off in your mac's network settings.

As every VPN has its own proxy settings, don't forget to turn off web proxy in VPN.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .