I have installed rEFInd in my mac by going into recovery mode -> open terminal -> csrutil disable -> cd "/Volumes/Macintosh HD/Users/username/Downloads/refind-bin-0.11.2" -> bash ./refind-install -> csrutil enable -> reboot
But on reboot it shows and loads the Apple icon first and then opens the Boot Recovery where I need to select my hard disk and restart the mac and it boots into macos without showing rEFInd option at the beginning. How to resolve this?

  • Can you confirm the file were copied to /Volumes/EFI/EFI/refind folder?. To do this you will need to mount the EFI partition. This can be done with the command sudo diskutil mount disk0s1. – David Anderson Aug 26 '18 at 2:08

EDIT: You'll have to run the ./refind-install program in macOS after you've run csrutil disable in the Recovery OS. This will most likely solve any issues you have with installation.

Original answer: I think your problem is that you've tried to disable csrutil through a terminal in MacOS, which won't work. Try following the steps in this article to go into Recovery OS, run csrutil disable; reboot in the Terminal, and then try going through the normal refind install steps. It's your choice if you want to re-enable System Integrity Protection afterwards, but again you'll have to do it through Recovery OS.

Hopefully this advice was interesting and useful to you, and I wish you good luck.

  • I've already done the same thing as whatever you have answered here. I was into Recovery OS. Didn't work. – user299956 Aug 26 '18 at 14:14
  • Oh, ok. Thanks for the clarification. I've edited my answer, I hope it helps. – Srevilo Aug 27 '18 at 6:27
  • This answer did not work. Tried Mojave and refind v0.11.4. – remik Aug 16 '19 at 21:31

You must log in to answer this question.