0

Have a Sandisk Ultra Micro SD card inserted into my MacBook pro using a Sandisk adapter. The card was originally in my Samsung Galaxy S7 however the phone stopped acknowledging it.

The card is recognised by my MacBook, I can copy content off it to back it up (which I've done) however when I run the disk utility erase function nothing is formatted. I click erase, name it, then MS-DOS (FAT) and run the process. The result can be seen on image 2, however everything is still on the memory card with disk utility staying the same as image 1.

Image 1

Image 2

I then try to format the card on Terminal. First I run

sudo diskutil list

to find the relevant disk, once this is done I run

sudo diskutil eraseDisk FAT32 Testing MBRFormat /dev/disk4

the result is the error message on the image below and with nothing erased or formatted.

image 4

If I download the software from https://www.sdcard.org/downloads/formatter_4/eula_mac/ then the process completes but nothing deletes.

I'm at a loss with what else I can try, I have tried different card adapters but none change anything.

2

If it appears to format but doesn't, the card is probably dead.

If an SD card suffers a write error the firmware will drop to read-only mode, which is essentially a non-reversible process.
If the official SDCard.org formatter can't deal with it, the likelihood is nothing can.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .