GPU-defect Macbook Pro 2011 does not accept csrutil disable anymore (10.13.6)

So… this worked quiet well. I was able to deactivate SIP with the stick. Then I realised that my OS and Start Volume still contained data so I had to delete it and reinstall macOS. For some reason my Wi-Fi wasn't working anymore (no symbol on the top right). So I had to install macOS with a ethernet cable. After the installation I trief to continue the tutorial:
(GPU problem - Boot Hangs on Grey Screen… )
with Part 2: "Improve thermal and power management"
But the kext was not found so I assumed that with my reinstall it got lost.

So I reseted the NVRAM and went through the process again. It worked and I did everything until part "Preventive measures for future use". But why is my wireless still not working and not even appearing on my top right?

And is it right that when I boot all these "white texts of black screen" are appearing before the apple logo? Can/should I deactivate this? But a big thanks already!


Partial answer addressing the "textmode" (verbose boot) problem:

What you called "textmode" in an earlier version of your question is really the verbose boot mode. There is nothing special or malicious or negative about it. Within the tutorial it is just employed to make it easier to get to know immediately the point of failure during boot should anything go wrong with the tutorial.

If you followed the tutorial it is to expected to be there. If everything works and if you do not like the aesthetics of it:

type in Terminal:

  nvram -p

that should output something like:

 boot-args  -v 

To get rid of this "textmode", you need tot type

sudo nvram boot-args=" "

Confirm its deletion with another nvram -p and see thge parameter -v for the boot-args gone. Next boot should then be graphical again.


Is Show WiFi status in the menu bar checked off in the Network pane of System Preferences?


  • it's not even in the list. There is only "Ethernet", "Firewire" and "Thunderbolt-Bridge". – Robert Yarborough Aug 25 '18 at 15:30
  • I've just seen that bluetooth is also not available and doesn't appear in the hardware list either – Robert Yarborough Aug 26 '18 at 7:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .