2

I reinstalled macOS couple days back, I found that I couldn't have a capitalized user/home folder anymore (Gio became gio). I'm used to having it with a capital.

Looked around online for a bit finding a way to change it using the root user. I reboot everything is all working well - permission are correct (as far as I noticed).

After updating the username, I notice that the Desktop, Downloads, Documents, Home, Pictures, Music etc. folders in the Home directory doesn't have their custom sidebar and folder icons anymore.

Does anybody know how I can fix this?

screenshot of my finder

  • Welcome to Ask Different :) Can you please edit the question and share the screenshot of the window that appears after navigating to System Preferences app → Users & Groups → Unlock preference pane → right click on your username → Advanced Options...? – Nimesh Neema Aug 25 '18 at 13:38
  • Thank you Nimesh! as soon as I opened it I saw the problem. My home folder name was still lowercase. I was pretty sure I changed that! – GioChocolateBro Aug 25 '18 at 13:43
1

A possible reason for this behaviour can be that the Home folder isn't set correctly for the user.

Launch System Preferences app and open Users & Groups pane. Click on the lock icon towards the bottom and enter admin password. Now right click on your user and select Advanced Options... from the context menu. In the pane presented verify if the Home directory is set correctly. You can click on the Choose... button to easily browse to and select the Home directory.

enter image description here

It is recommended to restart the system after making the changes to restore the sanity.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .