1

I have a failing Macbook Pro and have deactivated the discrete GPU by doing something [editors note: help us help you by detailing what modifications you made to deactivate the GPU].

Now on this machine, once I updated to macOS 10.13.6 it does not accept the "csrutil disable" anymore which leads to the fact that I am not able to go through this process:

GPU problem - Boot Hangs on Grey Screen

I already asked on several other platforms but nobody can explain me why it is not working anymore.
With the following Command (CMD-R-S) it seems that it does not go into the Recovery Single User mode and thus I have no sufficient rights to perform this action (csrutil disable).
Can somebody please help and tell me how to fix this?

Best regards

  • Comments are not for extended discussion; this conversation has been moved to chat. – bmike Sep 16 '18 at 18:20
  • There are major points of confusion here. See chat and this might need to be closed for Robert to edit more simply what’s going on here. It’s not clear if he keeps having problems trying to deactivate a GPU since each time he applies a software update, the os is back as designed or if there are cascading hardware failures. – bmike Sep 16 '18 at 18:22
  • Just had a defect MBP with 10.13.6 hands on. R+S seems indeed inaccessible now. But regular RecoveryMode (Cmd+R) worked and accepted csrutil commands. Please edit this question according to whether that worked for you or not. – LangLangC Sep 27 '18 at 14:10
  • @bmike This is strange. Once comments are moved to chat, I was told to continue commenting there in general. Yet you continue to comment here. & Looks like you are not pingable in that chat? This is not "how could you?" More: Wouldn't it be a good idea for your handle to be pingable in chat then? –– This comment is probably no longer needed once you've read it. – LangLangC Sep 27 '18 at 15:10
2

I had same issue but did not have to use another computer or usb drive. Via: https://apple.stackexchange.com/a/336676/302408

I was having the same issue. This is how I fixed it.

As we are not able to get to single-user-recovery mode by holding Cmd+R+S at startup to run csrutil disable, it is not taking you to SingleUserRecoveryMode.

I run the nvram command here in SingleUserMode

nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00

Then reboot

reboot

On reboot hold Cmd+R and it will take us to the GUI recovery mode. There click on Utility and open Terminal, here we can run the csrutil command.

csrutil disable

Then again make sure to run the nvram command then reboot

nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00

reboot

Boot into SingleUserMode Cmd+S to continue with the kext moving procedure. once done, go back to GUI recovery to re-enable SIP csrutil enable, then reboot once morew.

Once the Mac fully boots run nvram one last time as sudo

sudo nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00

Now do multiple reboots to test the machine boots back up properly. I have no issues now.

  • 1
    While this link may answer the question, it is better to quote essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg Sep 16 '18 at 18:18
0

This answer would require another computer and a flash drive. Also, you would have to either remove the internal drive or have have the ability to connect the Mac to another Mac in target disk mode.

Note: I assume your Mac has only one internal drive, so the flash drive would be disk1.

BTW: I tested what I could using my 2011 iMac with macOS 10.13.6.

The boot manager rEFInd can disable SIP. Also, rEFInd can be configured to boot in text only mode.

  1. You would need another computer to download the rEFInd zip file. Look for the link A USB flash drive image file. On my Mac, downloading created a folder named refind-flashdrive-0.11.3 in my Downloads folder.
  2. Next you would use the dd command to transfer the rEFInd image to the flash drive. I used the commands given below. Here, I assume the refind-flashdrive-0.11.3.img file is in the ~/Downloads/refind-flashdrive-0.11.3 folder.

    cd ~/Downloads/refind-flashdrive-0.11.3
    diskutil unmountdisk disk1
    sudo dd if=refind-flashdrive-0.11.3.img of=/dev/disk1
    
  3. Mount the EFI partition on the flash drive. For macOS, the command is given below.

    sudo diskutil mount disk1s1
    
  4. Add the following lines to the end of the refind.conf file. This will cause rEFInd to boot in text only mode. You can read the refind.conf file for more information. I choose a value of 2 arbitrarily.

    textonly
    textmode 2
    
  5. Plug the flash drive into your Mac.

  6. I assume you can not use the Mac Startup Manager because this would require a graphics mode display. However, if you assume the default item in the menu is first, then you can select to boot from the USB flash drive without using the screen. Follow this procedure:

    A. Restart the Mac and immediately hold down the option key. This will invoke the Startup Manager. You will have to hold the key down until you assume the Startup Manager is running.

    B. Press the key once. This should select the last item on the Startup Manager menu. The USB flash drive will always be the last item.

    C. Press the return to boot from the USB flash drive.

    If the computer does not boot from the flash drive, then try pressing the key more than once.

  7. When the rEFInd menu appears, select Change SIP Policy, then press return key.

  8. Wait for the screen to flash.

  9. Select About rEFInd to confirm SIP is disabled.

  • thank you! i put the image in my downloads folder but the terminal returns "dd: refind-flashdrive-0.11.3.img: No such file or directory" – Robert Yarborough Aug 24 '18 at 15:06
  • @RobertYarborough Did you extract the zip? If so, try using Etcher (a GUI tool for imaging files) to image the file to a USB instead of dd. – pixelomer Aug 24 '18 at 15:54
  • Unfortunately, when I tested my answer, I had SIP disabled when I entered the bless command. So, I needed to change my answer. Sorry that new answer is not as easy to implement. – David Anderson Aug 24 '18 at 16:38
  • @David Anderson – Robert Yarborough Aug 25 '18 at 9:19
  • 1
    @Robert Yarborough: Rather than post new questions a comments, you should actually post new questions. You can link back to this question if you wish. – David Anderson Aug 25 '18 at 12:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .