4

If I'm AirPlaying my screen, I likely don't want the room to see my notifications. Is there a way to automatically kill notifs when I connect besides manually option+clicking the icon in the upper-right corner each time?

3

Open System Preferences → Notifications, select Do Not Disturb in the sidebar and enable ‘Turn on Do Not Disturb: When mirroring to TVs and projectors’.

If you enable AirPlay without mirroring, then Do Not Disturb is not activated, but the notifications only appear on your primary monitor anyway.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .