1

I recently got a Mac running Mac OS X 10.6.7. I installed the software update that was available, and when I tried to restart it, it seemed to be going well until it froze on the original space background.

I tried turning it off and then restarting again, but I was faced with the same problem again.

How might I troubleshoot this further?

  • Welcome to Ask Different! I hope you come to find this site a useful resource. :) I've made some minor edits to your question, mainly to change some tags as they don't really seem to apply to the problem you're having. Also, "Mac OS X 10.6.7" refers to the operating system that's installed on your computer, not to the actual hardware you've got. If at all possible, can you edit your question (there's an edit link below it) to describe what model of Mac it is you're asking about? Having this extra bit of info may help in troubleshooting. – Monomeeth Aug 23 '18 at 4:45
  • I've posted an initial answer, but this may be a work in progress as we try and troubleshoot things and until you're in a position to provide further details. – Monomeeth Aug 23 '18 at 4:51
  • software updates are in the App Store. Where are you seeing the restart request? – CDK Aug 25 '18 at 2:57
  • When I enter the Software Update option in the apple menu. When the update installs it prompts me to restart, and I press the button, and then it freezes. I checked the updates section in the app store and it said No Updates Available. – romoon Aug 25 '18 at 2:59
  • Is the current OS 10.6.7? Have you tried making a bootable drive from whatever you're trying to update from? – Sam Jan 7 '19 at 15:01
1

I also had the same exact problem with trying to update the software. I have a 2011 MacBook Pro 13 inch laptop running Mac OS X Version 10.6.6. I did a little personal troubleshooting and none of the things listed above seemed to work. I did manage to fix it, however. I did this by starting my Mac up normally, clicking on the Apple logo in the top left corner, clicking on software updates and I let it load to the menu where it gives you the option to install. Instead of installing immediately from there I clicked on the more details tab closer to the left side on the bottom and deselecting the Airport update from everything. After I did that it updated and ran perfectly fine. I am not 100% sure it was the cause but after several hours of troubleshooting and looking up fixes on the internet, that is the only thing I could come up with myself and it seemed to work. I wish you good luck if you have not fixed it yet and if you already have well then I guess i am wasting my time. Anyways, have a good day.

| improve this answer | |
0

Troubleshooting is a process of elimination and often requires some patience. However, as a starting point, it may be worth you resetting your NVRAM.

Resetting the NVRAM

Here’s how to reset the NVRAM on your Mac:

  1. Make sure your Mac is not powered up at all.

  2. Press the power button and then press the command option P R keys. You have to make sure you press these keys before the gray screen appears or it won’t work.

  3. Hold those keys down until your Mac reboots again (i.e. a 2nd time) and you’ve heard the startup chime twice.

  4. Let go of the keys and see if your Mac reboots normally.

Let me know how you go via the comments below.

| improve this answer | |
  • Alright, I tried that, and the startup chime played twice, as expected. I restarted from the "Software Update" option on the apple menu, and the same thing happened. I tried pressing the restart option, but when I checked the software update option, it still said I need to restart. – romoon Aug 24 '18 at 0:50
  • Okay, I need some clarification re your above comment. It's just not clear to me what's actually happening at the moment, so I'll ask some questions. (1) What happens if you try powering up the Mac normally (i.e. does it boot into macOS or...)? (2) If you can boot in, what happens if you try to restart normally? (3) Likewise, what happens if you shutdown normally and then power up again from scratch? (4) What happens if you keep the <option> key down when booting up? (5) If you can't boot normally, can you boot into Safe Mode okay? – Monomeeth Aug 24 '18 at 3:23
  • Ah, sorry, I hadn’t replied yet as I was waiting for you to have time to try the others. Yes, you can just power off if you want. But, since you’re on that screen, you can try clicking on the HD icon and then pressing Enter on your keyboard to see if/how it boots. – Monomeeth Aug 24 '18 at 5:49
  • 1) I'm not exactly sure what macOS is, but the best way I can describe it is that it brings me to the home screen. (Sorry if that is unclear, please let me know if it is) 2) When I restart normally, it works, but when I check software update it still says I need to restart. 3) Can you be more specific? 5) I am unable to try that at the moment. – romoon Aug 24 '18 at 5:56
  • 1
    Ok, macOS is just the operating system (10.6.7 in your case) and you’re booting into that just fine. It seems to me your Mac is fine - it’s either continuing to install software updates that require a Restart (so you may need to go through that process a few times) OR it’s an issue because your system has only just introduced the Mac App Store app for the first time (because 10.6.6 is when Apple first released it). Instead of using Software Update, try launching the App Store app from your Dock to see if it finds any updates for you to install. – Monomeeth Aug 24 '18 at 6:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .